My Lovelace Plugins


#572

@thomasloven - Would it be possible to leverage popup card as a sort of “Please Wait” card that stays on screen for a pre-configured amount of time? I am interested in using this specific functionality as a way to slow down tap-happy users (i.e. my wife) in order to allow slower entities (Zwave dimmers, Light Groups, etc.) time to actually respond to a button press or service call before the user is allowed to tap another button. I was thinking, specifically, of using an embedded Markdown Card for the “Please Wait” text but ran into a bit of a roadblock with the timer portion. Thoughts?


#573

Thank you!!!


#574

I happened to scroll past this post and wasn’t sure if I had replied to you about this later or not, but I have realized that this can be fixed by adding overflow: hidden to the list of styles to apply.


#575

I don’t think you did, but the developer for the card in question did. It doesn’t work on iOS, but I can live with that.


#576

I have this card, modded with card-modder but cannot see the background image.

  - type: custom:card-modder
    card:
      type: custom:useful-markdown-card
      content: >
         Oggi [[ sensor.oggi.state ]] <br> [[ sensor.weather_report.state ]]
    style:               
      text-align: center
      backgroud-image: url("/local/lovelace/images/meteo.jpeg")
      background-size: 100% 400px
      --primary-text-color: var(--primary-text-color)
      --secondary-text-color: var(--secondary-text-color)
      --paper-item-icon-color: var(--primary-text-color) #small variation icons
      background-repeat: no-repeat
      border-radius: 20px
      border: solid 1px rgba(100,100,100,0.3)
      box-shadow: 3px 3px rgba(0,0,0,0.4)`Preformatted text` 

Where is the error?


#577

No idea. Are you sure the url is correct? I.e. can you navigate to it in the browser?

Also “preformatted text”?


#578

Yes i can go to the image in a browser.
I’m asking myself the same as you… what is “preformatted text”?
I just copied this style…

This is what i see:

33


#579

I see it now
backgroud-image: url("/local/lovelace/images/meteo.jpeg")


#580

Is it wrong?


#581

There should be an n in "background.


#582

Arghhhhh… ok, solved!
Can ypu tell me what is “preformatted text” ’


#583

Hi,

I am using Hass.io 0.84.6. I want to use lovelace-gen.py A lovelace configuration generator for homeassistant. I did’ everything as written, and as I try to run hell_command.lovelace_gen service i get every time error code 2. But I created the lovelace folder and inside main.yaml file with other files that I want to include.

I don’t understand where could be the problem.
I am using ‘python /config/lovelace-gen.py’ command.


#584

You have the latest version of lovelace-gen and your folder and file is at /config/lovelace/main.yaml?


#585

Sorry, it was my bad. First time using python scripts and thought that it gets automatically from GitHub. Now I add to my controller and everything works just perfect :slight_smile:

Thanks a lot for the help, and for script, love it :slight_smile:


#586

is there a way that this could be used to select the background for the view? maybe from the home view </lovelace/0> and be able to select the desired backgrounds to display with the other views? or possible with a random select type template from a list? I have tons of background images I use and I haven’t ran across this set up yet and don’t know if it is possible. Thanks for the awesome-ness of your work BTW!


#587

Hello,

I’m not quite sure if this is the right place to post my problem, but maybe someone can give me a tip.

I’m using “card-tools” in my Lovelace setup.
Everything worked fine till the 0.85 update yesterday.

I’m now getting:

…/local/card-tools.js?v=0.0.1:44:22 TypeError: null is not an object (near ‘…firstChild…’)

every time I’m opening the Lovelace interface or switching between views.

When deleting everything inside my ui-lovelace.yaml except

  • url: /local/card-tools.js?v=0.0.1
    type: js

and one view with one simple sensor badge I get:

…/local/card-tools.js?v=0.0.1:41:64 TypeError: null is not an object (near ‘…ha-panel-lovelace")…’)

Does anyone know what’s going on?

Thank you a lot.

EDIT: though it throws the error, everything looks as it should…


#588

I am getting from lovelace-gen.py script error that returns error code: 1. I did’t upgrade nothing. Runing the same version off add-on’s and Hassio as before, as this script was working perfect.


#589

I was about to say no, but then I had an idea and got held up for a few days trying it out.

Now I’d say kind-of…
What you could do is make a view with panel: true in which you put a layout-card, and then you style that layout-card using card-modder.

Unfortunately, I haven’t been able to get the background to extend past the bottom of the lowermost card using this method, but I’d guess that’s just a question about finding the right css options. Try playing around with the styles a bit.

- title: Background
  panel: true
  cards:
    - type: custom:card-modder
      style:
        background-image: "url(http://www.placekitten.com/800/600)"
        display: block #THIS IS ESSENTIAL!
      card:
        type: custom: layout-card
        cards:
          - type: entities
            entities:
              ...

#590

I can’t seem to reproduce this.
Do you have the latest version of card-tools?


#591

In the old version of the script return code 1 means that it was called with bad arguments.
Try getting the latest version from github and check the instructions to make sure you are running it the correct way.