My Lovelace Plugins


#673

Fold-entity-row has been updated for 0.86. I hope it should work now.


#674

That fixed it… Thanks!


#675

Not sure why it doesn’t work in my case still…
Everything is updated and I’m on 0.86.1
Anything obvious I’m missing?


#676

fold-entity-row should be 6d11d3, but is not shown in the updater.
I updated it manually.


#677

ah ok, thanks that worked!
Any reason the custom updater is not getting the last one?
Should I take it out of it to avoid issues?


#678

No, updater works as expected.
Devs are busy and forget to update a file or something. :wink:


#679

@thomasloven, i’m playing with the browser_commander and the lovelace-reload command.
Thanks once again for this!
The strange thing is, it works not in all views i have.
Looks like it doesn’t work in views with panel mode and the layout-card, but not sure.
Also the debug command to show the id doesn’t work in this views.
In normal views, it works, but all show the following errors in the log.

2019-01-24 14:31:10 ERROR (MainThread) [frontend.js.latest.201901211] http://192.168.1.123:8123/local/card-tools.js?v=090958:40:19 TypeError: document.querySelector(...).shadowRoot.querySelector(...).shadowRoot.querySelector(...).shadowRoot.querySelector(...) is null
2019-01-24 14:31:10 ERROR (MainThread) [frontend.js.latest.201901211] http://192.168.1.123:8123/local/card-tools.js?v=090958:42:19 TypeError: document.querySelector(...).shadowRoot.querySelector(...).shadowRoot.querySelector(...).shadowRoot.querySelector(...).shadowRoot.querySelector(...).shadowRoot.querySelector(...) is null

#680

I’m using a card-modder

Since last update 0.86.1 there are spaces (marked with arrows). I did an update to the card-modder and * card-tools file I deleted a cache, nothing changed.


#681

Seeing the same in the demo of JimPower.


#682

Fixed!


#683

Should be fixed with new version of card-tools.


#684

Also seems fold-entity-row is stuck on an old version in the custom card tracker.

I had to wget the latest to get 86.0 happy.


#685

WORKS! Awesome!


#686

Back in business!! Everything is working great again.

Thanks again for your hard work @thomasloven.


#687

DEPRECATED

Like, a day or so after I had posted this, @ljmerza made one that’s about a million times better: Light Entity Card

I will not be supporting this anymore. Use his one instead.

color-picker

08

This is still in the really early stages of development, but I think this might be my first card that actually looks like something, and does something to your devices… (except possibly toggle-lock-entity-row…)

Anyway. It’s a color wheel that lets you pick a color for your lights without opening up the more-info dialog…

Expect bugs. In fact, I haven’t actually tested it outside of my dev setup…


#688

The options for the card are a mess on github… no formatting…


#689

hi @thomasloven

I am trying to use the custom:vertical-stack-in-card in 0.86.1. Do I have to download the appropriate files to my config/www folder ? or does it come preloaded in 0.86?

thanks.


#690

Oops.
Thanks!


#691

Perhaps you should ask @ofek.ashery, who made vertical-stack-in-card…
But you could also read this guide https://github.com/thomasloven/hass-config/wiki/Lovelace-Plugins
Or perhaps take a guess what the prefix custom: might imply about whether it’s included by default or not.


#692

thanks for your help @thomasloven

@ofek.ashery and the only reason I asked is because I get this error when I try and use the custom:vertical-stack-in-card:

YAML Error: TypeError: Cannot read property 'startsWith' of undefined