My Mii/Yeelight/Xiaomi Bedside Lamp 2 stopped working

I used to have 3 of these lamps (MJCTD02YL), two running firmware 1.2.29 and one 2.0.30.

The 2.0.30 stopped working a few versions ago and back when it did, it wasn’t very reliable (some commands just never reached the device)

1.2.29 stopped working with 2022.10.5 (they’re showing up in Homekit Controller now and unavailable). The error message is Retrying setup: Timeout while waiting for connection to device <IP of lamp>:80

I have tried resetting the 2.0.30 lamp, but it stopped showing in the Homekit Controller card. I tried to set it up with Homekit on my iPhone and it works there, but of course it’s not in HA then.

I don’t want Homekit. I don’t care for it. I want my lamps to just work like they did before the update and for HA to control them.

I’m losing my mind trying to figure this out… How do I get it all working again?

Same problem here… Since 1 week bedseide lamp stops working … I delete integration and try to reconnect again via Yeelight entering the ip and HA doesn´t discover bedside Lamp 2…
I think is a problem related to the lamp firmware update… if anyone has a solution it will be appreciated.