My setup is dead - can anyone help please?

I had an issue with the SD card so set the pi up with an SSD, seemed pretty easy and all went well. Restored from a backup - that too went ok.

However it seems ZHA is now dead - I have the ConBee2 on a USB extender as i heard things about SSD interference.

Battery level monitors seem ok, no devices report unavailable, the error log is clear.

However, changing a device like a socket manually shows nothing in dashboard and similarly changing the device in HA has no effect on the physical device.

The NodeRed flows all load ok, device nodes show “online” but nothing does anything at all, debug nodes show no ZHA_event traffic at all.

Any ideas please???

Maybe you can show some specific. For example what is your machine? RPI 4
Booting from microSD or USB SSD? How do you explain my setup is dead?

My apologies, I have some other “issues” and i’m in a bad place at the moment.

I am running a Pi4 booting from SSD, I have a piggyback power management/fan board fitted and its powered from a 5A supply.

Its running but there seems to be no control connection between HA and the real world - devices are not unavailable - they just do not do anything at all.

Error logs are clean and green.

Setup was previously running ok on SD card but card died.

Do you install hassio or HA core? Regularly how do you connect to your RPI?

I use the default download HASSIO image and connect via ethernet on a static IP.

I tried reinstalling the ZHA integration but it wiped all my friendly names and custom entity ID’s - it also still did not work so i restored again back to the previous point

Do you understand basic Linux? if yes you should try my guide in installing hassio on RPI running Debian 10 which is very good and stable.

I’m afraid not - i have never used or even seen it, I;'m struggling to grasp even basic JAVA/JSON at present, find it very difficult at my age :frowning:

I have just deleted the zigbee integration and reinstalled it - it wiped out my names and ID’s but wanted to see if it was running

I tried adding a device via discovery and it failed to discover it.

It seems like the SSD stops the USB3 ports from being used on anything else - i moved the zigbee dongle to a USB2 port and it detected devices. The device also appeared in NodeRed on the ZHA_event

I then restored my setup again and yes its broken again.

It seems the only way forward is to delete the zigbee integration, delete all devices, add the zigbee integration and start from scratch, then go and edit/fix all the node red flows i have because the entity id’s are all defaulted again.

Not happy at all.

Is there no other way to maintain my devices whilst re-adding the zigbee integration???
Or just edit/reconfirm the path for the serial device???

It seems it was the USB port all along

I restored my data and left the dongle in a USB2 port

After a while the devices started popping up - its about 90% back now and actions have started running again.

No idea why but the SSD needs all of the USB3 port action it seems???

Good for you since its only a USB problem.

Anyway if you dare to try something which will allow you to run several other docker container to manage your docker then please try

You will need to create SSH Keys should you used mac then you just need to google or follow my step-by-step instructions. Else if you run Windows then you can follow this guide

At the end of my guide I provide a simple script which you can run on Debian to simplify the installation and you should have your hassio up and running with many way of access it via SSH/Remote/Samba

1 Like

Basically, it’s a problem of USB 3.x with all 2.4GHz Networks like WLAN and Zigbee. See Intel paper on this.

That’s why you should use an extension cable for your Zigbee stick and not stick it into a USB 3 port. Makes no sense anyway, Zigbee network speed is 10x lower than USB 1.1

1 Like

That is fascinating and very explanatory, thanks.

I’m also a radio ham and the dB figures are surprising.

I have the dongle on a 1m extension now, and it seems happy again, all devices have reported in apart from one RGB controller but i’ll go and reboot that shortly.

The culprit in this case is most likely to be the little US-USB U-connector pcb that is supplied with the board kit - its not shielded and exposes all the USB conductors - very nice for radiating RF signals straight into the dongle.

A decent shielded USB3 cable might help a little bit?