My steps to success for on Intel NUC

I don’t have nvme, just an m2. But my system has been running fine for a few months now.

I also did this straight on the nuc, except the dl part. had the image as file on the bootable usb. Did not unzip.

Who can help me with this? I followed all the steps and came to this. Into what do I need to restore it? What is ‘it’ and how to do it?

Can someone get a more detailed version of the last few steps of this process?

Thanks in advance!

‘it’ is your disk on which you want to restore the image.

Since you are running this on a nuc I presume there is just one disk? I did this on my m2

So on a root terminal
run gnome-disks
restore image/disk (under the waffle icon)
choose your disk
overwrite contents (you will be erasing the current disk)
I started gparted and checked bootable flag on the disk as well

1 Like

Just bought a NUC5i3, 8Gb/128Gb M.2 and using gnome-disks did not worked for me, it booted but was stuck before the end of the boot. I downloaded Balena Etcher and HassOS from Ubuntu live and then flashed HassOS image directly to SSD. Worked perfectly!

Worked like a charm.

Last question(s). Now I need to connect it to my wifi, anyone got any commands for that. Can’t seems to get anything right there. Thanks!

EDIT: Done!

I have the following Home Assistant set up working flawlessly for 15 months, managing 18 devices and over 200 active entities

NUC with i5-5300U | 2.3GHz
Windows 10 64bit
VirtualBox 6.1 / VM configuration below

For performance improvement, I’m working on upgrading the a HA setup to NUC i5-6260U | 1.8GHz | 16GB RAM running Ubuntu 20.04 with Virt-Manager but am still unable to get working in a stable & consistent manner see post

i219-v NIC. NUC10i7, running Hassio 4.8. Not recognizing network/IP address =/

The NUC is on my desk, SSD drive inside. No usb/sata adapter at hand, can’t use balena and will try gparted method. How/when can I set the fixed IP address for hassio?

Mines not even giving me a IP address. Which nuc u running

NUC 10

Thank you all for this great information on installing what appears to be Home Assistant’s flagship device, especially now that generic linux is no longer supported.

I think it’s important to get this documentation improved as it’s certainly been a headache hunting down all the information from a long thread, especially as a noob.

A $20 NVME USB adapter seems like an expensive solution for a single use case not to mention the delicate NVME port which isn’t intended to handle repeated installment.

I found a way that’s easier than using “gnome-disks”/“Disks” (although I did get this to work once) to flash the NVME SSD w/ Etcher on a “Try Ubuntu” live boot from Ubuntu Desktop flashed USB.

  1. Live Boot from Ubuntu USB
  2. Download/Copy Etcher + Hassio img
  3. Turn off safe mode in Etcher settings (for Etcher to recognize SSD)
  4. Flash SSD w/ HASSIO NUC img
  5. Reboot NUC

At this point, I’m having connectivity issues with http://hassio.local.8123 which worked on PI and VM. I attempted to edit the nmcli config based on T.H.U. recommendations for VM, notably connection to my router and rbpi’s old ip address(I’ve reused this ip address before so I’m doubting it’s a router issue). Something I did in nmcli bricked the device w/ blackscreen w/ white underscore requiring a re-flash after multiple attempts. :grimacing:

Could this be to do with some boot setting? - I can’t change my boot priority boot type from UEFI like in Intel’s OpenElec documentation as recommended somewhere in the community. UPDATE I attempted legacy boot but this failed to recognize my SSD.

If this is a new install, HA is available at http://homeassistant.local:8123 and no more at hassio.local:8123

Thanks tried this too, doesn’t connect.

Are you getting a IP address? Ive just said 2 posts up that the NIC in the NUC10 is not supported

Thanks for letting me know.

I haven’t been able to get an assigned ip or any network connection, but now no NIC support on NUC 10 makes sense.

At this point, I think I’m going to go with Proxmox VE because I’d also like to run Snapcast Server - and maybe other OS/containers.

Thank you for this. Three years later still relevant. I used this method two weeks ago to convert my Mac Mini VM + Vera Plus driven HA build to a NUC. Restored from a snapshot and I was up and running in less than an hour. I think most time was spent trying to find a keyboard to hit enter key on as we are a Mac house with all bluetooth Apple peripherals. I popped out the M.2 stick and loaded the image directly. plugged it in and I was good to go.

The VM build although amazing as I could mess around with it, randomly would have ethernet errors. Even though the VM was given a dedicated NIC. Drove my S.O. crazy because her Makeup scene button would randomly fail every so often and I would have to cycle HA. Since the conversion two weeks and no issues. I also notice my lutron integration (with scene buttons all over the place) reacts a bit quicker than it already was.

NUC / Vera Plus is rock solid combo!

I still use the MAC Mini to as testing grounds and the lady of the house is happy for the reduction in downtime when implementing new logic/devices.

AGAIN THANK YOU for the lay instructions.

Struggled with this for two days on my 6thgen celreron nuc 4gb ram 120gb sata ssd. Tried everything with both official nuc image and beta. Tried live cd, gparted, discs etc. and also booting from thumbdrive with nuc image etc. Nothing got the image written to my ssd. Could it be my 4gb ram that is insufficient for buring the image from Ubuntu “live cd” ?
Anyway in the end i just plugged the ssd directly into my computer and flashed the image directly and was up and running in less than 20 minutes. Shame on me for wasting many hours trying to do it the fancy way :slight_smile:

Flashed the img with balena etcher. Seems nothing works!

Instead of flashing to a USB stick and plugging it into a NUC with no OS (this failed for me) either flash directly to the NUC HD, or install a base OS and run the install script:

More info:

I flashed the file on my hdd with balena etcher, and nothing works. Your links are unsupported installations.