My steps to success for Hass.io on Intel NUC

Hi @eriktoft,

Can you expand on this, please?
I’ve been trying to install Proxmox on my NUC8i5 from a USB stick with the Proxmox iso image, prepared using Etcher, and getting an error when it starts to boot:

“Image Authorization Fail, System cannot boot to this device due to Security Violation.”

When you mention ‘putting the USB back to legacy’, how did you do that? Is it something you did to the USB stick, or something in the bios during the boot process?
This might just be the bit I’m missing!
TIA.

Yes, it was changing the USB settings in bios, I could not boot from bios without changing it back. But it was a different error message, I think, I got, so perhaps you need to change some security settings also in bios. Trial and error, a lot, did it for me:-)

Thanks for the information, that helps. I’ll give it another try soon.

This method just doesn’t seem to work HA starts to boot but gets stuck on Bluetooth firmware revision line and just does nothing.

Silly question time!
i have tried the dd method and etcher on both the internal emmc and an ssd all 4 installs end up at the hassOS boot menu, holding the enter key for a while causes a message to kinda display and from what i can make out the install is looking for a /boot/efi partition… Can anyone offer any suggestions on this?

this is as good an image as i can get!

1 Like

This I have exactly the same… cant get it working

I was able to install it on my nuc as following:

  • create a bootable linux live USB (I used debian, any other distro will do)
  • copy the intel nuc image from hassio on same stick (just as a file, you can use second usb if you like)
  • boot nuc from the live usb
  • start root terminal su or sudo -i
  • the live usb did not have gnome disks, so just install it apt update && apt install gnome-disks
  • start gnome-disks from same terminal (as root) gnome-disks
  • restore disk image (it’s under the ‘waffle’ icon)

I did startup gparted shortly and noticed the bootable flag was not set (I had deleted entire disk content and re-created partition table) so I enabled bootable flag

Also I did nothing to resize it, I can see the total size of the disk being used (120GB) mostly being used by /dev/sda8 with 100GB free space left

Hope it helps for someone

I want to give you an overview what I experienced.
I bought a NUC7CJYH2 with 8 GB Ram and 256 SSD!
With etcher I wrote the image to the SSD.
I started the nuc with an Ethernet cable connected.
It couldn‘t boot because the image wasn‘t save. So I started the bios and and changed the boot option.
Then NUC Booted, but stucked with connecting to the network. That’s why I deactived the WiFi in the BIOS.
The NUC Booted properly and I could see it on my dhcp server, but I couldn‘t connect to it.
I restarted the Nuc and updated the bios.
After a restart I had the same problem, but after 30-40 minutes the webpage loaded.
I installed the smb plugin and placed my last backup in the backup folder.
After a restart, I had to wait 30-40 minutes again and could load the backup.
Finally, my NUC booted in 45 seconds and everything is working like a charm!
It replaced my rpi2 and is running as a Live System for 4 days now (deconz and zwave included)

Success with your method and particularly with the approach of imaging the SSD externally first. The tip on identifying the ethernet identifier also helped so thank you.

I have traditionally run my HA instance on a smart plug that can be reset through some other system if needed, as a last ditch solution. If anyone is aware of another option that the NUC permits, that would be interesting.

I have been having this exact same issue for far too long… did you have any luck solving the problem?

I used balena etcher in an Ubuntu Live distro to image to a Samsung 970 NVMe m.2. This is an Intel NUC.

I’ve found it’s easier to use Rufus to make a bootable Ubuntu USB and then install to the drive. Try following THIS

Thanks, but the issue @Blair_Pollard and me have are specific when installing HASSIO as an OS directly to a NUC. I have been running it fine for over a year on a R-Pi but whenever I revisit my NUC I get stuck at the same place. I realize I could install Ubuntu or another distro and go that route, but I have enjoyed the simplicity of HASSIO on my R-Pi for a while and would love to maintain that.

Do you mean Home Assistant OS? Hass.io was never an OS.

yes, https://www.home-assistant.io/hassio/installation/

Hass.io was never an OS, and also no longer exists. I think you are confusing it with the old HassOS that is now called Home Assistant OS.

The docs haven’t all been updated since the name change.

It’s super easy to install Ubuntu and then Home Assistant Supervised (Hass.io). Maintenance is very easy.

Yeah, not sure on the nomenclature. At any rate, installing it on a NUC causes the above error being faced.

I did find the following as it relates to another distro but seems to be the exact issue (https://forums.balena.io/t/bluetooth-firmware-failed-intel-nuc7i5-intel-wireless-ac-8265-bt-4-2/1837). Seems the firmware looks to be out of date on the hass img.

The more I read into the above, it seems like I need to inject a library into the Hassio disk image: https://github.com/pop-os/linux-firmware/blob/master/intel/ibt-19-0-4.sfi

Anyone have an idea how this can be done?

Well, for anyone that has been stuck getting your NUC to boot with HassOS, here is MY solution… and it’s super easy: DO NOT USE A NVMe M.2 DRIVE.

After a ton of reading and experimentation I found that swapping out my Samsung 970 EVO Plus with a M.2 SSD, worked perfectly. Also, in my case this is for a NUC8i3 and NUC10i3. If this is in fact true across the board for all NUC models, this should really be documented/fixed.

Hope this helps someone… I’ve seen several of you stuck at the same place as me.

Bingo!

NVME disk now working on Intel NUC

This is what I did:

  1. download https://ubuntu.com/download/desktop, run live (try Ubuntu)
  2. download https://github.com/home-assistant/operating-system/releases/tag/4.5 (notice: Support NVMe & update barebox (#626) @pvizeli)
  3. run gnome disks -> restore disk image
  4. run gparted --> resize last partition

To enable WiFi:

  1. login as root
  2. type: login

nmcli dev wifi connect “SSID” password “password”

Make sure to include “”. This helped me a lot: https://unix.stackexchange.com/a/444433

4 Likes

Is not needed, will be done anyway on first start

I’m assuming from this that you imaged your existing HA install first and then just copied it back to the new NVMe? Is this easier than doing a backup and restore?
EDIT. Sorry, re-read. So your using Gnome to write the downloaded disk image to the NVMe. Got ya now. That’s easier than my method. Will give that a try.