My steps to success for Hass.io on Intel NUC

Thanks for letting me know.

I haven’t been able to get an assigned ip or any network connection, but now no NIC support on NUC 10 makes sense.

At this point, I think I’m going to go with Proxmox VE because I’d also like to run Snapcast Server - and maybe other OS/containers.

https://github.com/home-assistant/operating-system/issues/697

Thank you for this. Three years later still relevant. I used this method two weeks ago to convert my Mac Mini VM + Vera Plus driven HA build to a NUC. Restored from a snapshot and I was up and running in less than an hour. I think most time was spent trying to find a keyboard to hit enter key on as we are a Mac house with all bluetooth Apple peripherals. I popped out the M.2 stick and loaded the image directly. plugged it in and I was good to go.

The VM build although amazing as I could mess around with it, randomly would have ethernet errors. Even though the VM was given a dedicated NIC. Drove my S.O. crazy because her Makeup scene button would randomly fail every so often and I would have to cycle HA. Since the conversion two weeks and no issues. I also notice my lutron integration (with scene buttons all over the place) reacts a bit quicker than it already was.

NUC / Vera Plus is rock solid combo!

I still use the MAC Mini to as testing grounds and the lady of the house is happy for the reduction in downtime when implementing new logic/devices.

AGAIN THANK YOU for the lay instructions.

Struggled with this for two days on my 6thgen celreron nuc 4gb ram 120gb sata ssd. Tried everything with both official nuc image and beta. Tried live cd, gparted, discs etc. and also booting from thumbdrive with nuc image etc. Nothing got the image written to my ssd. Could it be my 4gb ram that is insufficient for buring the image from Ubuntu “live cd” ?
Anyway in the end i just plugged the ssd directly into my computer and flashed the image directly and was up and running in less than 20 minutes. Shame on me for wasting many hours trying to do it the fancy way :slight_smile:

Flashed the img with balena etcher. Seems nothing works!

Instead of flashing to a USB stick and plugging it into a NUC with no OS (this failed for me) either flash directly to the NUC HD, or install a base OS and run the install script:

More info: https://github.com/home-assistant/architecture/blob/506c13f2a15bc4d70aa2454ad596736c53b64be4/adr/0014-home-assistant-supervised.md

I flashed the file on my hdd with balena etcher, and nothing works. Your links are unsupported installations.

Supervised on Debian is not unsupported.

I flashed an 2.5 SSD with BalenaEtcher, installed in the NUC, and receive a “Image Authorization Fail. system can not boot to this device due to security violation.” Get the same error with the USB stick.

UPDATE: Opening the BIOS tool and selecting the SSD to boot from seems to have circumvented whatever security issue there was. Up and running.

Please help - my NUC freezes when I boot from USB and my googling has failed me.

I bought a NUC5i3RYK, installed brand new RAM and SSD (not NVMe), updated the bios, flashed hassio to a USB drive using Etcher, but the NUC freezes when I boot with the USB plugged in. I get some very brief output and then a blank screen with just an underscore at the the top and the functions legend at the bottom (press F2 for setup, etc.), except it’s frozen.

This was briefly printed before freezing:

Bootchooser: No valid targets found.

and

Nothing bootable found.

Maybe something went wrong with Etcher, even though it said success?

No wonder. You need to flash the image to the SSD directly. The easiest way is to remove the SSD from the NUC, connect it to a PC (10$USB to SATA adapter) and flash with etcher. Done.
In case you want to go the USB way, you have to flash a Linux live version to the USB drive, and from there flash the SSD. The HASSIO image is not bootable from USB

Yikes, okay. Thanks for the reply. I had thought steps 4-6 at the very top were pretty clear that I needed to flash and boot from the USB, but I guess the edit for NVMe also applies to non NVMe drives.

If I go the Linux Live route, is the end result still the same (only Hass OS installed on the SSD) or will I end up with HA running inside Linux as a container/VM? Trying to keep if relatively simple so I’d actually prefer to dedicate the NUC to HA for now.

the image downloaded from that github always says corrupt tried to install with various method etcher etc and all complain corrupt downloaded on 3 different devices HA need to sort their crap out with nucs so hard to make them work getting very fed up now.

Just wanted to give update in this thread. I got my new NUC8i5BEK with NVME running using the latest official release (4.12) and not the dev 4.5. So now it seems the official one works. My steps have been listed above but if anyone wants a fresh step-by-step that worked, then here goes:

  1. Make sure bios is updated to latest on NUC, Use F2 upon boot to explore bios and see what version you are on. Go to Intel site for your NUC version and download latest bios. Extract the files to a clean usb root directory. Put USB in the NUC and press F7 in the boot up and follow instructions. Very important to wait until this is complete and the computer reboots itself. Afterwards go into bios again (F2). Do Factory default (F9) and then you must go into advanced --> boot secure --> disable secure boot. Press F10 to save and exit.
  2. Download latest official release (v 4.12).
  3. Unpack the .gz file to a clean usb so only the .img file is in the root (note usb had to be NTFS for me due to large size).
  4. Download Ubuntu Desktop (right now Ubuntu 20.04.1 LTS). It will be a .iso file
  5. Make a bootable USB from this file (Windows: recommend Rufus and follow this guide https://ubuntu.com/tutorials/create-a-usb-stick-on-windows#2-requirements if you’re on Mac follow this https://ubuntu.com/tutorials/create-a-usb-stick-on-macos#1-overview )
  6. Put the bootable ubuntu usb and the USB with the hassio in the NUC and fire it up. Ubuntu will load, choose Try Ubuntu option and you will get to the desktop.
  7. Press Ctrl + Alt + T to open up a terminal window. Type: gnome-disks press enter
  8. Click on your NVMe disk. Then click on the “settings” icon (looks like gears) and choose “Restore partition image”.
  9. I can’t remember exactly how it looked, but a new window will open and you will have to choose the source. Thus open the USB containing the hassio and choose the .img file and press ok. The image will be loaded onto the NVMe-drive.
  10. Shut down the NUC. Remove both USBs.
  11. Start the NUC again. Hassio should load. I let mine be for 30 mins to allow for everything to download/update. Note I use ethernet and not WIFI, there might be an additional step needed.
    UPDATE: on my second install I had to disable WIFI within bios before it would start.
  12. Go to http://homeassistant.local:8123 to see that it’s up and running.

Hope this helps someone as noob as me in regards to linux :slight_smile:

4 Likes

This looks good - will try it.

The weird thing is that originally I set my NUC up using the exact same method as at the beginning of this post, then had to re-use the NUC for another purpose before loading HA again. Unfortunately no amount of trying including using the original img file from 2 years ago would now work.

This method actually sounds promising.

In 11. you write that you wait 30 mins for download and updates. Are there any output written to the screen during the 30 mins wait?

I’m asking because my NUC stops booting (no output to screen) after a few seconds. Excatly the same problem as Blair_Pollard had in this thread.

Ya, I gotta ask the same thing…I’m doing this in a virtual machine, and on a pi.
On the VM with no addon devices, it gets to port 4, says its starting version 3.2.9, and then sits there forever.
With the pi it gets the last “usb” device (which is the built in BT I think) the it sits there and every few minutes spams IPv6 link is not ready, power save enabled.

With the pi, it might be a bad powersupply, or a bad SD card…but I have no clue what it is for the VM (I’ve also tried as a SATA, don’t really want to try as a scsii or ide unless someone says to)

Mine is on a NUC - no VM, and stops at the same place, the Bluetooth drivers. No amount of waiting will make it go any further,

OK, I figured it out…atleast for me…I had an internal DNS server that wasn’t running, the Hassio apparently doesnt lookup secondary DNSs that aren’t listed in its own files.

example:
hassio is on automatic
custom internal DNS 192.168.5.95 -> this is set on home router
standard DNS 8.8.8.8 -> this is set on cablemodem which router is plugged into
hassio will use the one set on the router but wont use the cablemodem one when the custom one fails (windows and ubuntu will both do this)

Which NUC do you have? And are you booting from a eMMC?

Edit: one more thing, I have noticed the NIC LEDs are both off. Is that the same for you?