My steps to success for on Intel NUC

Just type login at the prompt. It is a debug mode with no username or password. Just type login to login.

Ok, I thought there might be settings for the OS or something. No need for me to poke around there then :wink: Thank for your answer!

I used your methode, and got it almost working. Only i did not get atcher installed.
I found (i think) an even easyer way.

Everything like you described, except;

  • download the NUC image directly from the site
  • from the /download folder extract directly to the SSD (right klik, extract)


I just rebuilt my Celeron NUC (2020). Previously I had HASS running in Docker on Ubuntu 20.04 LTS and I was getting random core errors when upgrading and the notification that was running an unsupported configuration.

I could not successfully image the main SSD using Ubuntu running from an SD card so I reverted to pulling the SSD out and flashing it from my NUC8i7BEH that runs Windows 10 Pro. As these NUC’s have USB-C I purchased a USB-C-SATA adaptor from Amazon (see below) and imaging with Balena Etcher. I did first try doing this with my MacBook, but I think the USB-C port on the MacBook could not supply enough current, so that failed.

Here is the device I bought, £12.95 in the UK from Amazon with next day delivery.

“Cable Matters USB C to SATA Adapter (USB-C to SATA Gen 2 10Gpbs) Thunderbolt 3 Port Compatible - 25cm”

WOW, I just booted my NUC from a fast ubuntu USB drive and imaged the SSD in place. I’m running an older i5-NUC [NUC6i5SYH with Samsung 850 EVO M2 SSD]. I downloaded the image and unpacked it while on the Linux desktop then imaged the disk using the built in disk tool, It was really easy. I think the whole process took less then an hour.

1 Like

Hi there, after 3 days of trying almost everything to install HA on my NUC’s (I have 2 same) I found a way how it works even on internal 32GB eMMC - so myth that it is not working with eMMC is BUSTED :wink:

Will be short, lot of details you can find somewhere above.

My config: pretty old second hand NUC 5GPYH (Pentium with 2GB RAM and 32GB eMMC) for same price as Rasperry Pi, but with lot of advantages.

  1. Update BIOS, latest is from 2020 (F7 on boot)
  2. Load defaults (F9) - do NOT switch system to Linux (as in my config I lost boot drive?!?)
  3. Use Ubuntu USB disk and boot from it (try Ubuntu)
  4. download official HA NUC compressed image (xz file) and put it to another USB drive
  5. under Ubuntu (steps 5-10): use built-in DISC utility, wipe all partitions from eMMC
  6. Run web browser, download Balena Etcher, decompress, save somewhere and run
  7. source will be image from USB step (4) target eMMC
  8. after etching is done, go back to DISK utility, you shoud see several partitions on eMMC
  9. go to first one (boot) right click and edit partition, mark as BOOT and UEFI
  10. shutdown Ubuntu, put away both USBs
  11. boot NUC (maybe try F10 and choose UEFI eMMC)
  12. HomeAssistant is running for the first time, it tooks less then a minute, you should see login: prompt
  13. type “root” (just word root, no " :wink: and press ENTER
  14. there is some warning that CLI is not installed, switching to emergency console (that is fine)
  15. type nmcli + ENTER -> you will see IP address of your NUC (like e.g. - depends on your DHCP server pool
  16. on other machine (eg your PC) use web browser, type that IP:8123 (eg.
  17. you will see HA logo with message “preparing, wait 20 minutes”…
  18. It took like 2-3 min in reality to have HA ready
  19. go back to NUC screen, type: “shutdown now” - will reboot HA machine
  20. after new boot, on NUC screen you will se again login prompt, again type root + ENTER
  21. now you will see text logo HomeAssistant and its IP address and green ha > prompt
  22. on other machine’s web browser you can start with creating user etc.

On other NUC I did it easier way, I “sacrified” eMMC and used SSD SATA drive 2,5"

Steps 1+2 same (update bios)

Just plugged SSD it to my PC through USB adapter, used Balena Etcher for PC, “burn” image (step 4 above) to it, installed on NUC, set it up as first boot device and continued from step 11)

Hope this helps.



wow…not sure why you had any difficulty. I was running Home assistant on a Wyse 5070 from the 32gb eMMC…and it wasn’t difficult at all. I installed Debian 10 which is supported…ubuntu is not although that doesn’t effect the install). I downloaded it, belana etcher to an usb drive, booted from that drive…and used the graphical installer. I then installed docker and home assistant supervised. During the Debian install, it asked where to install and the eMMC was one of the choices. Select entire disk and it cleans the disk and installs Debian 10.

Sorry, you are writing about apples, I am writing about pears :wink: ) (see topic - Hass.IO)

Before I run HA on same NUC, Win10, Oracle VM, on this virtual Ubuntu and then HA… Only need was 4GB RAM (so “plums solution” :wink: )

Here I am writing about HA as “operating system itself” - no Debian, Ubuntu or whatever as underlying system. There is a lot of topics saying about frozen NUCs etc. and impossibility to install it on eMMC so I’ve put here working manual how to do it.

Except HassIO no longer exists. :wink:

Good job though. I posted a PR to the HA docs a few days ago to get the NUC procedure updated so hopefully the official docs will soon be better than they currently are.

Sure, but if something change its name, it does not mean, it does not exist anymore :wink:

Again - for all - my post is about HomeAssistant (=operating system), not the Home Assistant Core (=application for other operating system).

1 Like

Just wanted to say thanks for this - worked perfectly!

I just had my RPi4 start to overheat and lose connection - decided to beef it up and go with a NUC and you’re directions here were great.

1 Like

same problem here… fixed it with extracting the xz-image into live disk environment and then used

dd bs=1m if=special-nuc.img of=/dev/sdX

that worked.

This was the solution for my install on HA on a NUC with an MVMe SSD. Thanks for the suggestion!

You’re welcome!

I think the mileage may vary depending on the hardware in the nuc… it is less standard then a raspberry… Some have been successful with this method and others not so… Anyway I’m glad if anyone can benefit.

I used another process to flash NUC SSD without removing it that was better for me:

Thanks very much. I tried some different methods but this one worked for me.

The only difference I made was to download the Home Assistant image using the Firefox browser in Ubuntu. Then I used that as my image for flashing in Etcher. Two USB sticks therefore not required.

Again, thanks!

Seems like a few people on the same journey as me in this thread

I’m trying to get Home Assistant OS installed on my Dell Inspiron i3050 and have etched Home Assistant image onto a flash drive.

Booted on the system but when it loads there is a menu there but i can’t see what it says! Seems to disappear off the screen leaving just the underscore

Eventually after pressing a bunch of buttons I get to the

Enter exit to get back to the menu

command prompt but then no idea what I’m supposed to do here because presuably I want to be installing something before i get here!
I want to run it off the internal drive…

You’ve got 2 options

  1. Flash the intended drive directly from another PC.

  2. Flash a live bootable version of Ubuntu to a USB, boot in, then download and flash HA OS to the HDD/SSD in the machine.

Thank you.
I’ve been trying the latter all afternoon and the damn machine keeps crashing halfway through one download or another…

May be a dumb question but is there any way to preload the files onto the usb for the live version to see them?

Edit. Managed to get to a point where I can get it going but breaks at this point every time.

Is there anything I can try other than Balena to install to the internal drive?

NB. I’ve cleared all partitions and formatted the drive so know it’s good

I’ve installed Home Assistant on two Intel NUCs, but they have been running well for more than a year. So my memory is vague. I think the menu is asking if you want to run from the thumb drive or install HassOS. If I recall, the default is to install, so press “Return”. There is no “progress bar” or any indication that it is running until you get the “HassOS-Boot” prompt.
At this point it is waiting for you to log on. You log on to “root”. (There is no password), then enter “help”.
That just shows that HassOS is running.
Now, you can log onto Home Assistant using a browser.

How does it “break”?