My steps to success for on Intel NUC

Just to give my version of installing Home Assistant OS on my NUC.
I made a bootable USB stick from a ubuntu server install and copied the Home assistant OS image on the the stick as well.
Then I booted up the NUC on the stick and dd’ed the image onto the disk and rebooted the NUC.

Hi all!

How do you make the NUC shutdown with a command from HA?

I made this automation, but it only seems to close the VM and keep Windows 10 and the NUC up.

alias: HA shutdown bij UPS low
description: ''
  - type: value
    platform: device
    device_id: 74d0aaefcb0dace0e806a238a6ee4874
    entity_id: sensor.ups_battery_runtime
    domain: sensor
    below: 700
condition: []
  - service: notify.mobile_app_sm_g970f
      message: 'UPS LOW: HA shutdown over 60 seconden'
  - delay: '00:01:00'
  - service: hassio.host_shutdown
    data: {}
mode: single


1 Like

I’m just getting around to trying this method but my Linux knowledge is very limited. I have my NUC running the Ubuntu boot disk, downloaded and opened up Etcher hower I was unable to flash the HassOS image to the NUC’s internal SSD as Etcher gave the error:

EBUSY: resource busy or locked, open '/dev/sda'

any tips on how to solve this?

EDIT: looks like I need to change teh permissions of the SSD to read/write. Trying to research to best/simplest way…

EDIT 2: For future reference I managed to use this command to write from teh Hassos image stored on a USB stick to the internal SSD which previously had ubuntu on it:

sudo dd if=/media/ubuntu/7C3AB6FD3AB6B40C/hassos_intel-nuc-5.9.img of=/dev/sda1

EDIT 3: rebooted NUC expecting HassOS to load / install but got: A bootable device has not been detected

EDIT 4: Tried again, this time with a little more Linux knowledge. Booted the Ubuntu USB disk again, deleted all partitions on the SSD using fdisk and then was able to re-burn the hassos image with etcher, reboot and all is good.

1 Like

After numerous attempts to get this working I finally have Home Assistant running on my NUC.

  • NUC 8 Mainstream Kit (NUC8i5BEH)
  • Samsung (MZ-V7E500BW) 970 EVO SSD 500GB - M.2 NVMe
  • Kingston 240GB A400 SATA 3 2.5
  • G.SKILL Ripjaws Series 16GB

First I tried flashing both of my SSD’s with Balena Etcher on Windows 10 machine. They would flash fine but could never get them to boot.

Installed Ubuntu on the Kingston SATA SSD and finished the install and got everything in there setup and running.

Downloaded the latest NUC Home Assistant image.
Downloaded xz-utils and used terminal to unxz the image downloaded.

Downloaded Balena Etcher and installed in Ubuntu and flashed the Home Assistant NUC image file that had been extracted from using xz-utils to the Samsung NVMe

Powered down the NUC, kept hitting F10 to select boot drive. Selected the Samsung drive and about 20 - 30 seconds later had a Home Assistant Login prompt.

After HA initial setup and getting Samba share going, I transferred my backup from my RPI and restored it.

I know it’s probably overkill but DANG! I had the RPI4 8GB with SSD setup and this is definitely a lot faster than that.

This ended up working for me, HOWEVER, I had some issues that I had to overcome first.

I originally burned the NUC image to my SSD using etcher on Windows 10, then inserted it into the NUC. It actually booted HA fine. Before configuring anything, I updated the bios (I was on an old version from 2018, I think like 036 or something), to the latest BIOS of 083. This is where the problems started.

Now HA wouldn’t boot from the SSD, it would get stuck saying:

loading ms-dos executable ‘/mnt/system/bzimage’

Even after using murphys_law’s method by burning it on ubuntu, still wouldn’t work. Eventually what I had to do was re-flash the bios (using the same latest 083 bios update file, though I re-downloaded it, not sure if that mattered). This time instead of using the “Press F7 on boot” method to update the bios, in the BIOS setup GUI in the NUC, I clicked the “update” button next to the current bios version. I did not click the one at the bottom that said “Update (F7)”, it was specifically the one near the top half of the screen that directly brought up an explorer window to choose the .bio file. I haven no idea if this made a difference though.

After updating the bios, and being sure the NUC finished and restarted itself, then I once again re-image the drive using murphy’s method / etcher on ubuntu. And finally after that it worked.

So I’m not sure what the problem was, but it had something to do with my BIOS. Perhaps it was corrupted during the first install.

1 Like

Bios issues? That’s kind of scary. Glad you got it ironed out.

Hello all,

i just managed to install Home Assistant OS on my NUC using Ubuntu Live and writing the image to my SSD using BalenaEtcher.

After the front-end was loaded I restored a snapshot and everything is working as it did before. The only thing I can’t get to work is logging in to Home Assistant on the NUC itself. I get the message “Welcome to Home Assistant
homeassistant login:”
But it doesn’t accept the same username and password as I use in the front-end. Do I have to configure this first somewhere?

you access Home Assistant through the browser…on the ubuntu desktop

Yeah I understand that I can access Home Assistant through the browser. That functions as it should.

But I installed Home Assistant OS directly on my NUC, there is no Ubuntu or other OS installed. When I attach a screen to the NUC, I see a login prompt. And I was wondering how to login there, because the username and password I use for logging in through the browser (on another device) are not accepted.

Just type login at the prompt. It is a debug mode with no username or password. Just type login to login.

Ok, I thought there might be settings for the OS or something. No need for me to poke around there then :wink: Thank for your answer!

I used your methode, and got it almost working. Only i did not get atcher installed.
I found (i think) an even easyer way.

Everything like you described, except;

  • download the NUC image directly from the site
  • from the /download folder extract directly to the SSD (right klik, extract)


I just rebuilt my Celeron NUC (2020). Previously I had HASS running in Docker on Ubuntu 20.04 LTS and I was getting random core errors when upgrading and the notification that was running an unsupported configuration.

I could not successfully image the main SSD using Ubuntu running from an SD card so I reverted to pulling the SSD out and flashing it from my NUC8i7BEH that runs Windows 10 Pro. As these NUC’s have USB-C I purchased a USB-C-SATA adaptor from Amazon (see below) and imaging with Balena Etcher. I did first try doing this with my MacBook, but I think the USB-C port on the MacBook could not supply enough current, so that failed.

Here is the device I bought, £12.95 in the UK from Amazon with next day delivery.

“Cable Matters USB C to SATA Adapter (USB-C to SATA Gen 2 10Gpbs) Thunderbolt 3 Port Compatible - 25cm”

WOW, I just booted my NUC from a fast ubuntu USB drive and imaged the SSD in place. I’m running an older i5-NUC [NUC6i5SYH with Samsung 850 EVO M2 SSD]. I downloaded the image and unpacked it while on the Linux desktop then imaged the disk using the built in disk tool, It was really easy. I think the whole process took less then an hour.

1 Like

Hi there, after 3 days of trying almost everything to install HA on my NUC’s (I have 2 same) I found a way how it works even on internal 32GB eMMC - so myth that it is not working with eMMC is BUSTED :wink:

Will be short, lot of details you can find somewhere above.

My config: pretty old second hand NUC 5GPYH (Pentium with 2GB RAM and 32GB eMMC) for same price as Rasperry Pi, but with lot of advantages.

  1. Update BIOS, latest is from 2020 (F7 on boot)
  2. Load defaults (F9) - do NOT switch system to Linux (as in my config I lost boot drive?!?)
  3. Use Ubuntu USB disk and boot from it (try Ubuntu)
  4. download official HA NUC compressed image (xz file) and put it to another USB drive
  5. under Ubuntu (steps 5-10): use built-in DISC utility, wipe all partitions from eMMC
  6. Run web browser, download Balena Etcher, decompress, save somewhere and run
  7. source will be image from USB step (4) target eMMC
  8. after etching is done, go back to DISK utility, you shoud see several partitions on eMMC
  9. go to first one (boot) right click and edit partition, mark as BOOT and UEFI
  10. shutdown Ubuntu, put away both USBs
  11. boot NUC (maybe try F10 and choose UEFI eMMC)
  12. HomeAssistant is running for the first time, it tooks less then a minute, you should see login: prompt
  13. type “root” (just word root, no " :wink: and press ENTER
  14. there is some warning that CLI is not installed, switching to emergency console (that is fine)
  15. type nmcli + ENTER -> you will see IP address of your NUC (like e.g. - depends on your DHCP server pool
  16. on other machine (eg your PC) use web browser, type that IP:8123 (eg.
  17. you will see HA logo with message “preparing, wait 20 minutes”…
  18. It took like 2-3 min in reality to have HA ready
  19. go back to NUC screen, type: “shutdown now” - will reboot HA machine
  20. after new boot, on NUC screen you will se again login prompt, again type root + ENTER
  21. now you will see text logo HomeAssistant and its IP address and green ha > prompt
  22. on other machine’s web browser you can start with creating user etc.

On other NUC I did it easier way, I “sacrified” eMMC and used SSD SATA drive 2,5"

Steps 1+2 same (update bios)

Just plugged SSD it to my PC through USB adapter, used Balena Etcher for PC, “burn” image (step 4 above) to it, installed on NUC, set it up as first boot device and continued from step 11)

Hope this helps.



wow…not sure why you had any difficulty. I was running Home assistant on a Wyse 5070 from the 32gb eMMC…and it wasn’t difficult at all. I installed Debian 10 which is supported…ubuntu is not although that doesn’t effect the install). I downloaded it, belana etcher to an usb drive, booted from that drive…and used the graphical installer. I then installed docker and home assistant supervised. During the Debian install, it asked where to install and the eMMC was one of the choices. Select entire disk and it cleans the disk and installs Debian 10.

Sorry, you are writing about apples, I am writing about pears :wink: ) (see topic - Hass.IO)

Before I run HA on same NUC, Win10, Oracle VM, on this virtual Ubuntu and then HA… Only need was 4GB RAM (so “plums solution” :wink: )

Here I am writing about HA as “operating system itself” - no Debian, Ubuntu or whatever as underlying system. There is a lot of topics saying about frozen NUCs etc. and impossibility to install it on eMMC so I’ve put here working manual how to do it.

Except HassIO no longer exists. :wink:

Good job though. I posted a PR to the HA docs a few days ago to get the NUC procedure updated so hopefully the official docs will soon be better than they currently are.

Sure, but if something change its name, it does not mean, it does not exist anymore :wink:

Again - for all - my post is about HomeAssistant (=operating system), not the Home Assistant Core (=application for other operating system).

1 Like

Just wanted to say thanks for this - worked perfectly!

I just had my RPi4 start to overheat and lose connection - decided to beef it up and go with a NUC and you’re directions here were great.

1 Like