My steps to success for on Intel NUC

same problem here… fixed it with extracting the xz-image into live disk environment and then used

dd bs=1m if=special-nuc.img of=/dev/sdX

that worked.

This was the solution for my install on HA on a NUC with an MVMe SSD. Thanks for the suggestion!

You’re welcome!

I think the mileage may vary depending on the hardware in the nuc… it is less standard then a raspberry… Some have been successful with this method and others not so… Anyway I’m glad if anyone can benefit.

I used another process to flash NUC SSD without removing it that was better for me:

Thanks very much. I tried some different methods but this one worked for me.

The only difference I made was to download the Home Assistant image using the Firefox browser in Ubuntu. Then I used that as my image for flashing in Etcher. Two USB sticks therefore not required.

Again, thanks!

Seems like a few people on the same journey as me in this thread

I’m trying to get Home Assistant OS installed on my Dell Inspiron i3050 and have etched Home Assistant image onto a flash drive.

Booted on the system but when it loads there is a menu there but i can’t see what it says! Seems to disappear off the screen leaving just the underscore

Eventually after pressing a bunch of buttons I get to the

Enter exit to get back to the menu

command prompt but then no idea what I’m supposed to do here because presuably I want to be installing something before i get here!
I want to run it off the internal drive…

You’ve got 2 options

  1. Flash the intended drive directly from another PC.

  2. Flash a live bootable version of Ubuntu to a USB, boot in, then download and flash HA OS to the HDD/SSD in the machine.

Thank you.
I’ve been trying the latter all afternoon and the damn machine keeps crashing halfway through one download or another…

May be a dumb question but is there any way to preload the files onto the usb for the live version to see them?

Edit. Managed to get to a point where I can get it going but breaks at this point every time.

Is there anything I can try other than Balena to install to the internal drive?

NB. I’ve cleared all partitions and formatted the drive so know it’s good

I’ve installed Home Assistant on two Intel NUCs, but they have been running well for more than a year. So my memory is vague. I think the menu is asking if you want to run from the thumb drive or install HassOS. If I recall, the default is to install, so press “Return”. There is no “progress bar” or any indication that it is running until you get the “HassOS-Boot” prompt.
At this point it is waiting for you to log on. You log on to “root”. (There is no password), then enter “help”.
That just shows that HassOS is running.
Now, you can log onto Home Assistant using a browser.

How does it “break”?

By break I should have said crash. Bad wording
Whole system hangs

I’ve ordered an m.2 to USB and gonna try etcher on a different machine and see if I have any more luck…

not sure how you are installing, but I’d suggest installing using Debian and docker. Just follow the directions in Installing Home Assistant Supervised on Debian 10

If you can boot from the m.2, then it probably will work. This is how I installed HassOS on my Intel NUC. Here are my notes:

The NUC image on the Home Assistant site is not bootable. Flash the image to your hdd/SSD directly.
I used an M.2 USB adapter and flashed to the M.2 drive, and after reinstalling the M.2 into the NUC, Home Assistant boots.


Thanks. Fingers crossed!!

I got to the prompt, have tried login, login blank, login login and all fail - has this changed?

Edit. NB
I know I should be able to access via browser but I know that won’t work at this moment in time as I’ve not given any details on how to connect to WiFi anywhere

The ABSOLUTE easiest way to get HAOS on a PC / NUC (the image is now ‘generic’) is to use a Linux boot USB (can be Debian or Ubuntu, doesn’t matter) then etch the HAOS image to whatever internal drive you choose from the live Linux GUI. This can be done by either using a second USB with the image file on it or by downloading the image from within the live Linux instance. I have done it both ways successfully.

1 Like

MY way is

when I stuff up HA that bad I can’t get to It

I take the drive out

Plug it into my USB to Sata

down load the latest image Use Etcher and put the IMG on the Harddrive(SSD)

plug harddrive back into NUC

do the onboarding thing

install Samba Share copy latest backup to the share
reboot nuc
then do a restore (beer time job done)

Which requires hardware other than that which everyone already has (USB thumb drive).

Can anyone tell me how I get the WiFi details in?
I’m installed, up and running but stuck at a login prompt which doesn’t seem to accept anything
I don’t see a way to get my network details entered

Login prompt where? You don’t use HA from the actual device running it, you need to use a web browser elsewhere.

Once you do the initial on-boarding to HA you will be able to change those settings. Having said that I HIGHLY recommend using Ethernet rather than WiFi.

I just ran into issues installing the latest Generic_x86 image on a 7th Gen NUC with NVMeSSD and disabling WLAN in the bios fixed the issue.

Is there a known process for enabling it again if you want dual IP addresses to the device?