My way to install HASSIO on QNAP NAS

Hello everyone! I have tried to install HA in Container Station, where I got the HA Core to work with my laptop inside my home network (behind NAT). Then I installed the OVA version in Virtualization Station to access Hassio/HA Supervisor edition. I setup Virtio for Network setting like you suggested. Everything installs just fine and I get to CLI and I can log in to HA. But I cannot connect to the GUI version in port 8123 with my laptop. Inside HA CLI, I give command “core info” and it says the IP is but my QNAP is on inside my home network. I also cannot see the IP (same problem as Bryan) under the Virtualization settings.

Edit: quick answer to myself. I tried to go to URL http://homeassistant.local:8123 and it worked! I used “tracert homeassistant.local” in my Windows CMD and found out the IP is for some reason. Awesome. Hope everything works now … :smiley:

(You might have known this already but) FWIW, one could probably also get the IP of your HA instance from your router, usually under DHCP section.


Has anyone created/installed HASSIO via the container station APi ?

It seems straight forward-ish. I’m doing some testing at the moment with another Docker image, but I’m getting stuck on the network settings ?

I’ve put in this, so it uses ‘bridge’

         "network": {
            "mode": "bridge",
			"join": true

But I’m getting the following error message

  "error": {
    "code": 400, 
    "message": "get network setting failed"

I create my dockers through portainer, als much easier to update them… but only HA in this case and not Hassio

The Container Station api looks promising, and if I could get it working (for my use case) it’ll be good to be able to spin up containers quickly, via the command line and keep everything in one place.

For those that are interested, I’ve posted a guide on how to create an HA Docker container via the QNAP (Container Station API)


I am using the QNAP TS-431X2, newest firmware =, its a armv7 32 bit machine.

I have adapted the command above:
docker run -d --name “hassio-supervisor” --restart always -v /var/run/docker.sock:/var/run/docker.sock -v /var/run/hassio-hc.sock:/var/run/hassio-hc.sock -v “/share/Container/Home Assistant/HASS/data”:/data -v “/share/Container/Home Assistant/HASS/log”:/var/log -e SUPERVISOR_SHARE="/share/Container/Home Assistant/HASS" -e SUPERVISOR_NAME=“hassio-supervisor” -e HOMEASSISTANT_REPOSITORY=homeassistant/qemuarm-homeassistant homeassistant/armhf-hassio-supervisor

No I am getting the following error:

[02:50:32] INFO: Starting local supervisor watchdog…
Fatal Python error: pyinit_main: can’t initialize time
Python runtime state: core initialized
PermissionError: [Errno 1] Operation not permitted

Current thread 0x75af4390 (most recent call first):

[cont-finish.d] executing container finish scripts…
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.

Any ideas for fixing?




first improvement:
I inserted the option “–privileged” and the container armhf-hassio-supervisor is running and creating futher containers, which are also being “up”:

But the armhf-hassio-audio:2021.02.1 is “exited” and is staying “exited”
and the qemuarm-homeassistant:2021.2.3 is on the status “created” based on the error message below:

Further ideas?




the issue with the armhf-hassio-audio:2021.02.1 is also based on the jemalloc issue.

Still trying to stop the container and fix the jemalloc issue with commenting out the the jemalloc library.
But there should be a possibility to install this library on the QNAP box, or keep it out of the Home Assistant images…



i also have started with HA in Ubuntu on VM (inofficial way). But with the new .OVA official Image for VM e.g. Qnap its for me the best Usability. I set up in the VM an automated Every-Day-Snapshot. And before i take the new Updates, i generate a VM-Snapshot. it takes less then minute.
And if something going wrong, i can step back in also less then a minute. in a very bad mistake i can jump from one snaphost to other, for searching a stable Version and going from this. But was not needed because the HA Devs do a great job. Thanks a lot on this point.
Very happy with my environment in the Virtualization Station. it saved me time hours for backing up and waiting for updates.

Thanks alot!

Many ask or have problem how to install Home Assistant .ova on a Qnap. Here is a little Video on YouTube i found.

Hope it’s ok to copy the link here.


I’ve struggled and struggled, and now you post this and I got the OS up and running on the Qnap in minutes. Haha. Thanks a lot!

But what about Does that still have to be managed with a Ubuntu VM separately?
With the guide above I guess we’re only getting the HA OS, but not the IO part. Sorry for my “rookieness”.

I am still stuck on the last command, since the link seems not to be working.
curl -sL | bash -s

If you have got the OS running already, per the video above. Your HA install is done. Find the ip address of that VM, and you can already connect to your HA from your web browser.

So, the below does not apply to you any more:

… and you are probably using an old old old install guide that is not applicable any more today. Throw that guide away.

But what about that IO module? Or have I confused things?
It wasnt easy figuring out how easy it is to set it up. Why arnt there more simples guides on youtube, only that german one?!

I can connect to the HA and it’s up and running. So nothing else needed in terms of installations/modules etc to get things going now?

One additional question. This time regarding the HomeAssistant and the coding itself. I have figured out some basics, but would like to start with the following: I want to dim my lights when Starting KODI on my Nvidia Shield. And turn off the lights when starting to play a Movie. Any info/guides or other that you can point me to?

I’ve figured out the simple function of turning off the lights when the Shield turns on Netflix - but that doesnt make much sense. HA basically thinks I’m playing Media as soon as I start Netflix. Or the Shield sends that info.


Yes. If the webpage is ready, you can create local account, and you can get to your default dashboard – your HA installation on QNAP is done. Cannot be simpler.

The term is history for a while now, the developers (and this community) have stopped using that terminology for maybe 2-3 years now, trying to simply things and minimize confusion. I guess yes it could be confusing for anyone following an old guide these days. So, let’s forget whatever your install guide (from 3 years ago) has said.

Re: the additional question -
Very likely you could find answers by searching discussions in this forum, or search here (Integrations - Home Assistant ( to see what is already possible on your HA install, without any extra code install, and read documents. And if you still have question, let’s start a new thread - since your Shield/Kodi thing has nothing to do with QNAP at this point.

1 Like

I have also installed th OVA version, and so far I am quite happy with this solution.

However there is one drawback: I have not found a way to export/import configurations / backups. Because the hard drive in the VM is virtual, it apparently cannot be accessed from outside, and other way round it cannot access any share on my NAS.

Or has anyone found a way to resolve this?

with the OVA you have supervisor installed where you can install extra add-ons like Samba Share, SSH & Web terminal access…

do you have any issues with the zigbee stick? mine is getting disconnected lately, all the time. And can not fix it.

Anybody else have any luck with this recently? I’m trying to run the official HAOS 8.2 OVA in virtualization station on my TS-253 (Intel Celeron).

It installs and boots, but when I assign an IP address to the network adapter, the qemu-system process CPU usage on my NAS immediately jumps up to 100% and stays there, despite the VM hardly using any CPU at all. I’ve tried both Intel Gig Ethernet and VirtIO options.

Anybody else seen similar CPU usage issues?