My way to install HASSIO on QNAP NAS

HI ALL! since a week I have managed to install HASSIO on a QNAP (turbo) nas, Since I have found multiple guides on how to install home assistant in docker on a qnap nas but NO HASSIO installs yet I decided to give it a try, and it worked.

Currently I am still “working” on the guide, I have wrote down the steps with some single words but I am planning to re-do the installation and complete it with screenshots etc, If there are questions or additions please let me know.
The opening post will be a living document

Hardware:
I use a Qnap Nas model 453U, 8gb ram, though it should work wit most Qnap turbo nas’ses which support “virtualization station”.

You can find whether your NAS is compatible HERE QNAP List of nasses with support for virtualization station

The method consists out of 2 main steps:

1. Setup virtual machine in QTS, using virtualization station and Install HOST-OS

2. Install HASSIO

Extra Infos: (not done yet, links below)

  1. passing USB Device through
  2. getting Aeotec z wave stick to work
  3. determine network port (i.e. ‘ETH0’)

1. Setup virtual machine in QTS, using virtualization station and Install HOST-OS

1.1 Download a host OS, I have chosen to use UBUNTU server 18.04 LTS
See here: [https://www.ubuntu.com/download/server]

Based on this decision I have written this guideline.

Store the image somewehere where you can access it from your nas(preferably on the nas itself in a shared folder)

1.2 Install Virtualization station 3 on your QNAP Machine, this can be found in the QTS AppCenter
( In the AppCenter click on "All Apps" and search for virtualization Station.)

1.3 Open virtualization station and create a new VM

Click: “Create VM”

Fill out the following popup according to your needs and preferences.

I run a 4 core, 8gb ram system with only HDD’s, since I decided to provide the VM first with 2 cores and 2gb of ram, I will check the load on the system every now and then and when i notice that more power will be necessary I will provide it with more resources.
Since I am migrating from a PI and (currently) not running very heavy addons i expect this to be sufficient. This can be adapted later.

For me this looks like this:
CPU cores: 2
Memory (RAM) 2gb
CD Image select your saved install file for the HOST-OS here
hdd Location: create image and selected a location which suited me.

Network:
If you are using multiple LAN-ports on your nas you can select the desired port here.

Click OK and start the VM.

You then see a small screen in the virtualization station, if you click on this a VNC connection starts and you can “setup” the Host-OS via your browser.
Follow the steps.

1.4 access Host-OS via ssh
Once the installation is done you should be able to access the newly setup VM via SSH.
To do this I use Putty (on windows, with mac or linux I think this functionality is built-in).

  • Determine the IP adress of your VM, I just checked my router, probably there are multiple different methods (ipconfig via vnc?)

  • connect via SSH

  • update and upgrade the host machine (is this needed with a fresh install?)

2. Install HASSIO

Since we have actually “just” installed a generic linux installation the installation method for installing HASSIO on a generic linux machine works,

to dot this run these commands via SSH in your VM: Source, thank you Frenck!

sudo -i
add-apt-repository universe
apt-get update
apt-get install -y apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq network-manager socat software-properties-common
curl -sSL https://get.docker.com | sh
curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh" | bash -s

Once this is done you can access your home assistant via the web browser:
http://server_ip_address:8123 (SERVER IP IS THE IP OF YOUR VM!)

In the beginning there pops up a display which says “preparing, installation can take up to 20 min”

refresh regularly and after a few minutes HASSIO starts.

congratulations!, you have just installed HASSIO on your QNAP nas!

To do’s for this Guideline:
-Make a lot of screenshots and add them
-Add “tips and tricks”
-Use USB devices
-Select “correct” eth port in setup of i.e. samba addon (leave “” empty instead of ETH0, see here: SAMBA Share (2.0) not working with HASSIO 0.49.1 NUC eth0
-Use Aeotec zwave stick (https://forum.qnap.com/viewtopic.php?t=131048)

If you found this helpfull and / or have some comments or questiosn please feel free to ask or comment!

2 Likes

I love you ! you are my hero ! Thank you you solved everything I needed to have ! THank you !

Thanks for the guide. I have followed your directions and was able to get Hass.io installed on my TS-453B unit. Haven’t tried putting my Aeotec Zwave stick yet, but I figured I would use the NAS as my dev environment at least for now

Thanks. This is great. Able to load it on my TS-251. Using Aircast to Airplay to my Google Homes.

Brilliant!!! I have been going back and forth between hass.io on the RPI and docker containers on the QNAP. Finally, this is the best of both worlds :slight_smile: Thanks!

1 Like

Thanx, it’s working.
I had problem with Pi-Hole add-on “port 23 already in use…”
Also problem with DuckDNS.
Solution for both of them was fixing DNS:
https://datawookie.netlify.com/blog/2018/10/dns-on-ubuntu-18.04/

hello, I have installed ubuntu, but I am a novice, from where I install hassio, from the root of the qnap by SSH ?, or do I have to get into some volume or folder? Thank you.

Inside Ubuntu, just install the prerequisites and run the script.

20

I have entered the qnap by ssh, but there I am lost, I do not know where I have to put the orders below, if directly there where it is seen in the photo or I have to go somewhere within the qnap. Thank you

add-apt-repository universe
apt-get update
apt-get install -y apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq network-manager socat software-properties-common
curl -sSL https://get.docker.com | sh
curl -sL “https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install” | bash -s

You said you installed Ubuntu. Did you install Ubuntu in a VM? If so, Ubuntu gets a new IP address on your network. You need to enter your UBUNTU installation and run the commands from there. This has nothing to do with QNAP OS.

Ok I understand that it is there in the image, but it does not leave me the option to paste the text and I do not know if I know how to put some commands like the bar is before the sh |

??

Just type them?

Or SSH into the Ubuntu machine.

but this “|” how does it get ?, what letter is it?

It’s a “pipe”. On US Keyboards it is shared with the \ key

I’ve already found it on my keyboard is the admiration, I’m Spanish.
thanks for everything and it is installing. We’ll see how.

Hello, in the end I got it installed, now I get the follow you doubt, how do you access the folder where the configuration?

Like the idea of the VM but getting error on the last curl command

[email protected]_1806l:~# curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install" | bash -s
bash: line 1: 404:: command not found
[email protected]_1806l:~#

I get 404 error with the last command as well.

The url changed:

curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh" | bash -s
1 Like

Hi! any idea how to get combee or zwave stick to work? i dont se any tty when i type /dev/tty