My way to install HASSIO on QNAP NAS

ssh into your NAS
For Conbee:
insmod /usr/local/modules/ftdi_sio.ko
For Conbee 2
insmod /usr/local/modules/cp210x.ko
For Aeotec Z-Stick 5 (For TS-453Be, it only works on the front USB2 port)
insmod /usr/local/modules/cdc-acm.ko

You will have to do it everytime the NAS restarts. Or create an autorun script using https://forum.qnap.com/viewtopic.php?t=130345

2 Likes

thanks! seems to work now

Helped me a lot!!!
thank you so much

You’re very welcome and welcome to the community!

I just noticed that the installation codes where not up to date anymore (like @Sebastien_Bo mentioned) I just updated this in the opening post.

Did you run into any (other) trouble (to eventually update the opening post).?

BR
Bjorn

not Sir
:innocent::innocent::innocent::innocent:

Bjorn, great job and tutorial! Thank You!

to use USB stick (Aeotec Z-wave stick) i added USB device do VM:

then just to confirm connect to VM via SSH and check if Z-wave stick is connected:
ls -la /dev/ttyACM*

if it’s listed just restart homeassistant container (docker restart homeassistantcontainer and enjoy z-wave in HA in VM

Hi, Thanks for the guide. I have a problem, how do I set up the HAss.io autostart?

Hi Mariano,

Standard hassio starts as soon as the VM starts, to start the VM automatically on a reboot of the qnap Nas you can do this in the settings of the virtualization station (3?).

Please let me know what the current behaviour is when the qnap reboots to understand your problem better.

Best regards,

Bjorn

I solved, now I have another problem, the packages don’t work for me.

Hi!

Thanks for the guide! It was very easy to follow and install HA.Only thing i missing how can i put the /config folder to one of a shared folder on the nas? I can only reach the config folder inside the docker right now.

Regards
Gabir

Im seriously out of my comfort zone here… I’m mostly doing this to learn things. Im not very knowledgeable in any of the required fields so feel free to just ignore this post if you just sigh when you read this…
I had set it up as described by Björn and it worked like a charm. Yesterday I updated QTS and Virtualization station, as a consequence . Now the hassio do not respond on 8123. Thought the VM server had gotten a new IP so i checked, but I am able to connect via SSH using PuTTY. The VM seems ok… hassio and docker have their own IPs but as I recall they had the same IP last time and hassio, as far as my knowledge goes, should respond on the VM ip on port 8123… but it does not! Perhaps I should ask this in a qnap fora but this is where it all started so… I have no clue at all whats wrong.

Edit: ok…I gave up. Gona buy me a Raspberry PI…

Hi Gabir,

I dont know whether it is a possible and foreseen idea to put the configuration folder OUTSIDE of the Hassio environment, i dont think so.

What you can do for easy access is installing the Samba add-on that way you can access the hassio share just as easy as via a shared folder of the Qnap nas.

Best regards!

Hi Kallemyran,

Sorry to hear that you (had) to give up.

Unfortunately I cannot follow your problem completely… did the hassio instance start of your VM?

maybe a “simple” sweep and new setup of the VM+hassio is a solution…

What I normally do is making backups from the individual VM’s within qnap virtualization station.

Havent needed them yet though…

Hi BjornH,

Thanks for Your reply!
Samba is what i’m using now, and it is working fine. I just tried to use a shared NAS folder inside the ubuntu for the config - hoping for an easier backup - but without success.
But You are right , it is absolutly not necessery.

Regards!

Thanks for your response Bjorn.
Yes one way is of course to just start over clean, but I want to know what went wrong so not to get in the same situation again I’m just born that way ;). Sadly my knowledge in Linux is missing and it just takes to much time right now. perhaps I’ll be back. Right now I’m just using a simple cloud setup that takes care a few things I can not live without
Again. Thanks for your response and the guide that worked flawlessly

I have a big problem on Hassio on a QNAP.
I installed it some months ago and runs well for a month.
then I get a blank screen on reboot

I reinstall it (losing all my work) and redone all

after a month it is like before…
is there a way to fix without lose all my work?

Based on what you tell me I cannot understand what exactly happens…

If the question is “can I rebuild my system without doing everything over again” basically yes IF you have made backups / Snapshots (either from the complete VM or within hassio).

I am not a linuxwizard or programmer and cannot do much more than google a bunch of shit together…

However if you setup a home assistant instance again I HIGHLY recommend you to make backups / snapshots (and also save them elsewhere!).

maybe if you explain your situation a bit more in detail someone is able to help you.

BR,

Bjorn

I don’t know what happens. Basically nothing. I simply update my nas and reboot it. And after my vm doesn’t work. It is the second time. First time was - months ago, I work hard to reconstruct system, and when all was ok I had to go out for work, forgot to set a backup.
I have no backup.
When I took the image with clean system I had the same error so after many try and different settings in image convert I get it work.
I think it is system boot that does not work due to something in image.
There is a way to read files in image to copy config on a new install or a way to rebuild boot?

That sounds quite annoying…

I don’t know whether there is a method to restore the VM/get the config files out of it.

Maybe try to install the VM on another system?

Or maybe the guys on the qnap forums know…

I am sorry but I cannot help you on this…

thanks, I was messing around with lcx containers until I stumbled on this guide. Pretty straight forward and im happily surprised how little resources it uses on a 253Be with 8GB

Using a usb device like the CC2531 also works without a hiccup.

What might be a handy addition to make it even easier is to have ubuntu server automatically update itself: https://help.ubuntu.com/lts/serverguide/automatic-updates.html