My Zigbee2mqtt devices do not connect to the router I want to connect to


I have a coordinator connected to Synology Nas in which I have installed Home Asssitant.

On the upper floor I have two zigbee routers so that the signal can arrive correctly and the devices are distributed and that they get an adequate signal quality to all.

Previously it worked perfectly by clicking on the options and selecting “Permit Join (Router xxxx)” my zigbee device would connect where I indicated it to do so, but since some time ago (I don’t know if it was caused by an update) it only allows me to connect my devices if I click on “Permit Join (All)”.

This causes devices that have a router next to them (-0.5m) and would have a good connection to connect to the coordinator that is on a different floor of the house.

Sometimes it connects randomly with luck, I don’t know how to get it right the first time but it is very rare.

Does this happen to anyone? I hope you can help me. Thanks for your help.

Zigbee devices will work out the route they think is best. If they’re working, don’t worry about how they’re connected, or the LQI.

@Tinkerer I understand from what you say that by connecting it with “Permit Join (All)” it will connect where it works best?

But it happens that if I disconnect one of the routers because I move it to another place and place another one in the same place as the previous one, it does not connect the devices to the new one, it remains disconnected.

Thanks for replying!

Well, don’t do that.

The end-devices of some brands will spot that they’ve lost their connection to the mesh and will try to find a new connection. Some won’t - Xiaomi are well known for being very “sticky” and more likely to fall off the mesh than reconnect.

If you want to relocate things then you can reasonably expect to have to re-pair many of your end devices.

1 Like

I just happen to me with Xiaomi, but that’s what I meant in the last thing you say, I delete them from Zigbee2Mqtt and when I try to put them back it doesn’t let me put it in the router I want if I don’t check “Permit Join (All)” it won’t let me integrate it because it doesn’t detect it when before it worked.

I am using a couple of Aqara Sensors and i notice this behavior happening too. But when i join them with Permit Join(All) and then manually bind to a specific router(im using Ikea Tradfri repeaters) i can get it to bind successfully. It works well with the Door Sensors, Motion sensors etc.

I only had issue with the Temp Sensor from Aqara no matter what i do, not able to bind it to specific router…

But overall it works fine for me.


I have similar issues with Xiaomi sensors. The weird thing is, even though I’ve tried repairing it by placing it right next to a “router” (IKEA plug or something else), it seems still wanting to connect to the main router.
If anyone knows how to force it to use a specific router instead, please share the secret :slight_smile:

Same for me. I used ZHA before and there joining through the router works, so I know it’s possible. Now I wanted to try Z2M and it doesn’t work. I’m activating Permit join (Blitzwolf socket B), and holding the button on my Xiaomi water leakage sensor. The sensor resets and confirms binding by blinking twice but nothing appears in the web interface. The link quality directly to the coordinator is appalling. Theoretically zigbee mesh should sort it out, but it doesn’t. And if @jonathanathe states it worked before, I suspect a bug. Anybody knowledgable enough to help out please?

I have the same problem. In my case I have a number of A-OK curtain motors (with Orvibo Zigbee modules) that seem to work ok if they happen to connect to my Ikea fixed lamp, but work unreliably if they connect directly to the CC2652. Commands are delayed etc with the direct connection to the controller, which seems counterintuitive, but would seem to be the case. For troubleshooting/debugging I would like to connect the devices to the same Ikea lamp, but I am not able to selectively enable just one router for joining. Or at least the devices will not connect that way.

I have the same problem. Suddenly all devices are connected to the coordinator. The coordinator is in the basement so most devices have bad lqi.

There are only two routers with good connection to the coordinator. Devices used to connect to them which worked fine. Now its nearly unuseable.

I had the same problem with the Aqara temperature sensor, they just would not pair with a router. Door sensors no problem. Just permit join and press the button, and they would grab the nearest router. But not the temp sensor.

I managed to solve it by first explicitly removing the sensor in MQTT, and then permitting joining only to the desired router. Then the sensor would pair via the router.

So it seems like the sensor remembers the last node it was connected to, and refuses to pair/connect to any other, when you just press the button for 7(?) seconds. Explicitly removing it first, seems to fix the issue. Well at least for me :slight_smile:

1 Like

I’m having the same problem here. But I have some logic when temp goes down and I cannot do something manual in case they fail. There should be an automatic way of linking when they are not connected.


The problem is that it’s up to the device to reconnect to the mesh, there’s nothing you can do remotely.

The best thing you can do is:

  1. Switch to Zigbee 3.0 devices since those usually are more likely to pick another router if they need to
  2. Ensure you’ve got routers that have a strong signal, and aren’t incompatible with your other devices
1 Like

Thanks for the info.
Does anyone know any other brand/model for zigbee temp sensor different to Xiaomi Aqara?.


To be honest, I’ve had no issues with mine.

You can find a list here. I’d suggest avoiding anything that’s a Tuya rebrand (anything from Tuya or with a device ID starting TS).

I’ve had success with Develco’s motion sensor, so maybe try their temperature sensor.

8 posts were split to a new topic: Zigbee2MQTT devices not connecting