MyQ/Homekit integration problems


I’m using HA with both Homekit and a MyQ Chamberlain garage door component. The MyQ shows up in HA as a generic cover, not a garage door cover. If I leave it that way, then Homekit recognizes it properly. However, if I customize the device_class to garage, then the device no longer shows up in Homekit. Here’s the customize code in my configuration.yaml:

      friendly_name: Garage Door
      device_class: garage

Any ideas how I can fix that? I want it labeled as a garage door explicitly so Homekit will not allow it to be opened without authorization.

Thanks for the help!

I had this problem too, and I solved it by removing the bridge device from Homekit and then re-adding it. Hopefully that works for you too.

It looks like this will be the default device_class for MyQ in an upcoming release, according to this change:

Incidentally, I also built a workaround specifically to bypass this authorization, since it worked better for me: Open Sesame: Garage Door Automation with HomeKit