MyQ stopped working - "Credentials are invalid"

My MyQ integration has stopped working. The message I get when trying to use it is:

Failed to call service cover/open_cover. Opening of cover Garage Door failed with error: Credentials are invalid, update username/password to re-try authentication.

I couldn’t find how to edit the username or password, so I deleted the integration and re-added it, but no luck. I also changed my password in MyQ to make sure that I had the correct password, but it’s still not working.

Same issue here. Any resolution?

I’ve got nothing. Still hoping for some responses here.

Having the same issue. Stopped responding with same error, tried re-adding the integration with valid credentials, same issue.

Same issue here. I think it started failing right after the 2022.10.5 upgrade.

Log Details (ERROR)
Logger: pymyq.api
Source: components/myq/
First occurred: 06:39:30 (23 occurrences)
Last logged: 07:19:45

Authentication failed: Error requesting data from Cannot connect to host ssl:default [Try again]

More info: this problem resolved itself by ‘power cycling’ the VM HA is running in. A ‘system reboot’ and a ‘restart HA’ (from the HA GUI) did not resolve the problem, but a complete reboot of the VM did. It might have something to do with my custom hostname getting changed back to the default homeassistant.local by the 2022.10.5 upgrade, or perhaps that was just a coincidence. For me, all systems now appear to be back to normal and operational (except using the default homeassistant.local hostname).

Thanks. A system restart worked for me too.

Thanks this thread really helped me out. I got this same error coincidentally the day after “pairing” my Telsa Model 3, and then un-pairing after noticing the MyQ Tesla integration has a subscription.

While I may or may not get the subscription long term, I had assumed this “limbo” status I put myself in with my MyQ account was the root cause (“Created” my account associated with my main MyQ account, then removing the Tesla from this account without accepting the 30 day trial).

Instead, the simple reboot of my VM fixed it!