Nabaztag/tag, the smart rabbit is back! (•ㅅ•)

The (second) first wireless rabbit is back

Fully functional with its new Home-Assistant powered heart.


Follow the istructions on this page to set up a new Nabaztag/tag serverless firmware:

Just remember that you can use your Raspberry Pi as host for this firmware files (just create a folder named “www” in the config folder and put the “vl” directory right there).
After installing this new firmware, it will be possible to control the rabbit using the Home Assistant user interface:

or you can just make your own automations to control LEDs, ears and voice messages.

Here is my “Nabaztag Package”:

If you don’t know how to use a package have a look here: https://home-assistant.io/docs/configuration/packages/ or just create a directory named “packages” inside the “config” folder, put the file there and add this line to the configuration.yaml file:

homeassistant:
  packages: !include_dir_named packages

Inside my Nabaztag Package I used these sensors:

The rabbit will show the informations using the frontal LEDs and the body language (moving the ears). You can set a schedule to show the infos, wake and set it to sleep at the time of the day you want.

Beside keeping his own Nabaztag personality, marking the hours and chit-chatting with funny sentences during the day, you can use the Google TTS service to make it talk.
The Nabaztag can also play webradios, just edit the list of urls inside the file.

It’s possible to download the original Nabaztag voices available in 10 languages (br, de, en, es, fr, it, ja, uk, us) at this page: http://share.nekmo.com/python-nabaztag/mp3/zip/.
The Google TTS obviously works with many other languages.

3 Likes

@blackgear, the UI is ready :slight_smile:

Great, man!

Aggiungerei: 'sticazzi!

What about the italian voice recorded from Violet? does it work? and tts is from google too? :smiley:

2 Likes

Yep, he/she/it talks with the Italian Violet mp3 files too :wink: . The google TTS works fine and it’s also simple to use, just use the script like this:

    - service: script.nabaztag_talk
      data:
        message: "Buongiorno!"

really nice job !

I’ve two of these little rabbits at home and I use openjabnab.fr to interface them to my HA configuration.
All of my need is OK with my configuration, unless the 3 LEDs that do not work.

Can you make your configuration works for 2 nabaztag ?
Can you make those 3 LEDs work as they works on the violet time ?

hey doune,
I’m afraid I can’t do it, just because I can move the rabbit ears and change the led’s color only if the nabaztag is using the serverless firmware. I guess it could be possible to make it for 2 rabbits but still, they have both to use that firmware. Sorry.

Hi,

I can’t seem to get this to work.

I have installed hass.io onto a raspberry pi and got it working nicely.

I have made a directory called www inside the config directory and copied the vl folder into that.

I have also redirected the bunny to The raspberry pi but it won’t connect.

Have I missed a step?

Thanks in advance,

Nick

What about the firmware in the nabaztag @kikura?

Thanks for the speedy response. I have upgraded the firmware in the Nabaztag to the redox version.

I’ve also managed to install the vl folder into an Apache server and connect the bunny to that. Just can’t get it working on Hass.io.

If you type the nabaztag ip address in your browser, can you see the following page?

No. It just says the site cannot be reached. That is on both a hassio installation and raspbian.

In fact, where is the html for the configuration page? All I can see is the bc.jsp file and lots of mp3 files.

Well, the page will be inside the nabaztag, but you have to follow the insstructions in this page to make it work:


using the hassio as web server for the installation.
As first check, can you reach this file on your network?

http://hassio.local:8123/local/vl/config/surprise/uk/1.mp3

if not maybe you are not sharing the vl directory in the right way

Yes this works. It plays the sound of Nabaztag snoring.

Good, so you changed the Violet Platform inside the Nabaztag settings with
192.168.0.your-hassio-ip/local/vl
like
192.168.0.100/local/vl (or maybe with the http:// now I don’t remember)
?

Thank you!

That was it. I had it set to 192.168.0.xxx/vl

Now it works.

1 Like

I have a Nabaztag rabbit in vgc for someone to breath new life into if anyone is interested in making me an offer. email me [email protected]

Hey! What you have done seems awesome! I’ve got a few Nabaztag:tag and one Karotz and I’m really looking forward to make them work with HA (for Karotz I may develop my own package later using OpenKarotz firmware).
Anyway, I’m new to HA and I think it would be great if you did a fully integrated “component”, where you could choose the services you want to use (because I had to create Google Distance Matrix and AirVisual API keys but I don’t need them). Also after setting up all my API keys, I still get this error when checking my config:

^[[01mTesting configuration at /home/homeassistant/.homeassistant^[[0m
^[[01;37mFailed config^[[0m
  ^[[01;31mautomation:^[[0m ^[[31m^[[31m
    - Invalid config for [automation]: required key not provided @ data['action']. Got None
required key not provided @ data['trigger']. Got None. (See ?, line ?). Please check the docs at https://home-assistant.io/components/automation/

Can you please help me with this? Do you have any idea on how to fix it? I have an almost brand new configuration, with nothing in the “automation” mapping.

Hi.
I have two Karotz, loaded with Openkarotz.
One led.

I also have found Italian Mp3s.

will it work If i update?

For the talk it points to a shell script:

nab_talk: bash /config/www/vl/talk.sh

Where can i find this?

I’m using SSL and a DNS to connect.
It doesn’t work when I put either https://dnsname:port/local/vl or dnsname:port/local/vl in the Violet Platform.
The rabbit change from blue to orange and stay orange.
I can only access the vl directory with https://dnsname:port/local/vl
Thanks