Nabu Casa Cloud and new iOS Compantion 2.0

Using Nabu Casa cloud service to access my HA.

I am trying to connect iOS Companion 2.0 to my HA. When connected to same wifi I can locate it, it shows up like xxxx.duckdns.org:8123, but when I try to connect it gives an error. (Unknown error. Timeout).

My configuration.yaml has this entry:

http:
  base_url: !secret base_url
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem
  ip_ban_enabled: true
  login_attempts_threshold: 5

Should I remove this, since I am using Nabu Casa cloud? Afraid it could brake something, so I can not access my server again.

During setup the app does not get access permission to the ssid name on ios13 anymore (Apple…). Hence it only auto-populates the external url field.
Here’s what to do:

  1. Enable access to location always from ios settings
  2. In the app enter your url as internal url, see that it connects and has your ssid as internal location.
  3. The app should now have the checkbox to enable nabu casa cloud available and you can activate that. External URL becomes disabled at that point and the app should connect via the cloud when outside your wifi.
1 Like

Thank you so much!

For me the above steps do not solve the issue. No matter what I do, I never get a checkbox. I’m on iOS 13.3.1. Do you have any suggestions?

Have you figured out how to get the check box? I don’t seem to get it either. I’m wanting to use HA companion as my GPS tracking, but shortly I may have to go back to Life360

No, I haven’t. Can’t help you.

I have same issue, I cannot get checkbox to enable nabu casa cloud eiter.

I was having the same problem but was able to get this to work after enabling the Webhooks at the bottom of the Home Assistant Cloud configuration in my Home Assistant instance. After enabling this, I reinstalled the iOS app and tried again. I now get the checkbox for “Connect via Cloud” in my connection settings of the iOS app. I hope this helps someone else.

Thanks Mike,

That helped! I had Webhooks enabled already, but what I think helped was to re-install the app instead of just resetting it.

Happy Boris!

1 Like

Same issue here! Except, after struggling back and forth I have a button „Home Assistant Cloud“, but, thus enabled, remote access still does not work and, after a short time, the „external URL“ field refers to the internal IP and the „internal URL“ field is empty, and the HA Cloud button is deactivated. What could be the matter here?

Webhooks are shown, but cannot be en- or disabled. I have reset and reinstalled the app a couple of times.