Nabu Casa connection not working - how to troubleshoot?

Left the home for a vacation and noticed that Nabu Casa is not working. I have VPN:ed into the HAOS instance and it shows “Connected”. Cert seems to have been renewed and valid for some months more.

For good measure I have toggled the Remote Control switch and rebooted everything but still no go.
I have checked the logs but nothing obvious.

Where should I look?

And what happens when you try to connect through a web browser to your Nabu Casa URL instead of the mobile app?

Same thing - blank for 15-30 seconds and then showing “Unable to connect” as above. Even when launching from Nabu Casa account page.

1 Like

I have trouble connecting through Nabu Casa now too. So it might be the problem isn’t at your end.


I’ve been having a similar issue. Can’t connect to my HA unless I’m on my local wifi. Let me know if any of you have figured this out. I noticed the problem 2 days ago.

Still no go for me despite reboots etc. Using my local OpenVPN connection to access my HA instance.

I’ve rebooted my server and it seems to be working now.

1 Like

What is your config? Running on HAOS? I have version 8.2 waiting to be installed, maybe I should give that a try… Don’t feel too good being away and pushing updates though…

I’m using HA as a virtual machine running on a Proxmox server. I subscribe to Nabu Casa for remote access.

Same here but using ESXi. Will try to reboot and see what happens.

Reboot did it for me as well!

I’ve gotten this problem twice now in the past few days. I shouldn’t have to reboot just to keep the connection to nabu casa. Something else is causing this connection to break, but I have no clue what that might be.

I have the exact same issue today.
To be honest, I have been experiencing some NabuCassa connectivity issue few times in the last few weeks but usually it just recovered after a simple refresh.
This time, I have restarted HA, tried even logging out of NC in HA but nothing helps.
Both HA and NC state that the system is connected but I am unable to get to the system, it just keeps loading and then display error 403.

Did any of you ever find out anything else to try beside restarting HA and doing the rain dance?