Nabu Casa disappears from UI, after force reset passwort and unlink all connection in my Amazon account

Hey all,
today something strange happens. It was necessary to change the password of my Amazon account and to unlink all existing connections to it, due to an Amazon related problem. The hotline technician had recommended to do so. After this it was necessary to reconnect many stuff to get Alexa and so on running again. But one thing I had not thought of at all no longer works → my Nabu Casa Cloud!

I recognized, that the “Home Assistant Cloud” entry disappears from the configuration page. Further I found following in my notifications:

Logger: homeassistant.setup
Source: components/cloud/
First occurred: 11:43:38 AM (1 occurrences)
Last logged: 11:43:38 AM

Error during setup of component cloud
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 254, in _async_setup_component
    result = await task
  File "/usr/src/homeassistant/homeassistant/components/cloud/", line 233, in async_setup
    await cloud.initialize()
  File "/usr/local/lib/python3.9/site-packages/hass_nabucasa/", line 275, in initialize
    await self._start()
  File "/usr/local/lib/python3.9/site-packages/hass_nabucasa/", line 279, in _start
    await self.client.cloud_started()
  File "/usr/src/homeassistant/homeassistant/components/cloud/", line 151, in cloud_started
    await asyncio.gather(*(task(None) for task in tasks))
  File "/usr/src/homeassistant/homeassistant/components/cloud/", line 119, in enable_alexa
    await aconf.async_enable_proactive_mode()
  File "/usr/src/homeassistant/homeassistant/components/alexa/", line 60, in async_enable_proactive_mode
    await self._unsub_proactive_report
  File "/usr/src/homeassistant/homeassistant/components/alexa/", line 31, in async_enable_proactive_mode
    await smart_home_config.async_get_access_token()
  File "/usr/src/homeassistant/homeassistant/components/cloud/", line 179, in async_get_access_token
    self._token = body["access_token"]
KeyError: 'access_token'

My HA instance works fine locally, but the remote UI via nabu casa do not:

Any idea how to fix the problem or how to resync the access token?

A few people are having similar issues after restarting HA in the last hour or so. Must be an issue at NabuCasa. I’m sure they’ll sort it out soon.

Always sucks when you change something and then run into a problem that is not related. Can cause you to stress and make some major changes for nothing.

1 Like

I have the same issue

1 Like

Thx guys will keep an eye on it!

Same error here. I got message in the log that access token to Alexa is invalid.

I thought it was my fault and I tried also to remove Home Assistant extension from Alexa app.

Same error here. Deleted the .cloud folder from my config folder which brought the cloud option back in the UI but it still doesn’t connect. Hopefully they’ll resolve it fast.

+1 on the +1

OMG! I’ve lost half of day. Almost decided to reinstall, thank you for confirming it.

Yeah, this was exactly my way to solve it. Meanwhile the option disappears again.

Back up for me without any changes. Looks like it was likely an issue on the NC side.

yes, working for me again also.

Though some have gotten functionality back by deleting certain files, you should not have to do anything. For anyone experiencing issues, try restarting HA.

after a restart, mine is now back again.

Yepp, nice to see it running again.
But honestly I would expect something like an announcement via mail or similar in such situations. Can’t imaging that the nabu casa guys haven’t seen this. Or appears this maybe only for some users?
I really got in trouble, because I thought I broke something with the master reset of Amazon…

Yes, it was not across the board, or you had to restart HA to experience it. By the time it was investigated it had already started to heal itself more or less so publishing about a disruption was too late. It should be back for all without the need to make any changes.

For me it was necessary to delete the folder “.cloud”, reconfigure Nabu Casa and Home Assistant on Alexa app.
Now it is working.

I did the same, but it was likely not needed if we had waited longer. If you are still seeing errors in your log when syncing Alexa (even thought it is working) try a restart.

did the same, works again.

Directly from the NC support:


There was an issue with Alexa/Amazon API which has been addressed and everything should be working now. If you are still experiencing an issue please try a restart of Home Assistant.

Sorry for the inconvenience.