Nabu Casa : Remote access is being prepared. We will notify you when it's ready

Are you toggling the remote on from within HA or are you often using

Neither, as when this issue happens, I have to go the local ip of HA, then notice the “remote access is being prepared” message under the remote control section of Home Assistant Cloud. If I try to access it won’t allow me to connect and gives some similar message to ‘cant reach remote instance’.


was having the same issue. Logged-off and on, restarted HASS, both several times. Nothing seemed to work. Send an email to Nabu Casa support. Got an email back within the hour. They advised me to not just restart HASS but the host. In may case a Raspberry Pi. Unplugged the power, plugged it back in, waited 5 minutes and… MAGIC. worked like a charm again.

Big thanks to Nabu Casa support!

Same exact issue for me on my RP4. Even when I reboot host sometimes won’t come back up. Then when I reboot host again after about 30 minutes or so it will. I’m keeping my DuckDNS open until I get this figured out, don’t want to be locked out away from home.

I’ve tried toggling, signing out, etc. The link gives me the same error as above regarding “connection failed” but in HA & Nabu integration it’ll say “please wait…” but that’ll stay that way for days.

I may need to try Ibennai’s auth_providers trick.

Just feeling out here: Is anyone else using Polly TTS and having this issue?

since recently I started experiencing the same issue. Tried all the trick and hints from this post, nothing helps.
Opened a ticket with NabuCasa but they do not respond for few days at all.
So, I’m wondering if everything is OK with nabucasa guys?

This becomes a real issue as I’m not abel to access HA from outside (local IP works just fine).

Yes, for me the same problem also seems to have started after I switched from Google TTS to Polly TTS. Might just be a coincidence but worth checking anyway

happening to me too, right after i started Webhook for dialogflow.
After every HassOS restarts, the remote access shows being prepared and I have to go and restart the Home Assistant Core and that would bring the remote access working again.

This hadn’t had for a couple of weeks, so I thought it was fixed but unfortunately it popped back up. Managed to catch this in the logs, not sure if its relevant:

2020-03-16 17:09:29 ERROR (MainThread) [hass_nabucasa] Unexpected error in on_start <bound method RemoteUI.load_backend of <hass_nabucasa.remote.RemoteUI object at 0x7f9631231810>>
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/hass_nabucasa/", line 125, in load_backend
    resp = await cloud_api.async_remote_register(
  File "/usr/local/lib/python3.7/site-packages/hass_nabucasa/", line 16, in check_token
    await cloud.auth.async_check_token()
  File "/usr/local/lib/python3.7/site-packages/hass_nabucasa/", line 145, in async_check_token
  File "/usr/local/lib/python3.7/concurrent/futures/", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.7/site-packages/hass_nabucasa/", line 160, in _check_token,
  File "/usr/local/lib/python3.7/site-packages/hass_nabucasa/", line 217, in _cognito
  File "/usr/local/lib/python3.7/site-packages/warrant/", line 172, in __init__
    self.client = boto3.client('cognito-idp', **boto3_client_kwargs)
  File "/usr/local/lib/python3.7/site-packages/boto3/", line 91, in client
    return _get_default_session().client(*args, **kwargs)
  File "/usr/local/lib/python3.7/site-packages/boto3/", line 263, in client
    aws_session_token=aws_session_token, config=config)
  File "/usr/local/lib/python3.7/site-packages/botocore/", line 826, in create_client
    credentials = self.get_credentials()
  File "/usr/local/lib/python3.7/site-packages/botocore/", line 431, in get_credentials
  File "/usr/local/lib/python3.7/site-packages/botocore/", line 926, in get_component
    del self._deferred[name]
KeyError: 'credential_provider'
2020-03-16 17:09:31 INFO (MainThread) [hass_nabucasa.google_report_state] Connected