Nabu Casa : Remote access is being prepared. We will notify you when it's ready

I have been using the remote UI for a couple of months now and never seen this problem.

“Remote access is being prepared. We will notify you when it’s ready.”

Hope the service is running ?

HA 0.94
Not Hassio.

Just done a reboot and all is well.
It came back but i don’t no why it came up with error.

Had the same issue just now - rebooting solved

I see this guy @peglegreg has had some problems as well.

Seeing the same problem this morning. I still have access other ways, but hopefully this isn’t an ongoing problem.

have you rebooted?

Nope not yet. I have other ways to access it for now. Just saying I hope it’s not an issue that requires a reboot every few days.

Got same problem. Quite frequently these days.
Rebooting solved.
Hope it’ll be fixed soon.

Thanks for linking to my issue. I was hoping that giving it a day or two would help, but even with reboots and log in/log outs the last 2 days it still will not connect. If anyone has any other recommendations to try I am all for it.


I just wonder if it’s worth sign out of nabu casa and try again from within the home assistant cloud.

Same thing happened to me. I noticed it after updating to 0.94.3
Restarting HA solved the problem.

1 Like

Finally I keep having the same problem and restarting isn’t resolving it. I think it got to intelligent and it is now immune to previous solutions… :yum:
But seriously, anyone else facing it and solved it permanently somehow?

I only had it the one time about a month ago and it went away when I was able to finally restart.

Hi, did you manage to get it working? I’m having the same issue. the issue with “Remote access is being prepared. We will notify you when it’s ready.” ?

Relogin and restarts are not helping.

Hey Ivan,

I am not sure if it helps, but my issue was related to Nabu Casa. I did not use remote access at the time, but I opened a ticket with them on their website and they were able to sort out the issue for me.

Cool, thank you for your reply!

After a restart or reboot, it may take some time to make the connection again.

I have ran into the same issue. Neither login out and back in, nor rebooting seems to solve my issue.

@peglegreg, do you remember how Nabu Casa solved your issue?

Hey Ilias,

I didn’t do anything other than open a ticket through the Nabu Casa website and they were able to fix things behind the scenes. I would check with them first to see if they can help you out.l

1 Like

Here’s how I solved it and got my remote control back in a few simple steps:

  1. In the frontend, log out of HA Cloud.
  2. Delete the .cloud folder.
  3. Reboot the device (just restarting HA didn’t help).
  4. Login to the HA Cloud.
  5. Wait a few minutes and then you’ve got your remote control back.

Here’s my config.

    - type: trusted_networks
    - type: homeassistant

Hope this will help someone else the same way I have received a lot of help from other members on this forum. #PaybackTime :slight_smile:

This is happening more and more frequently for me. As a reboot usually solves it, its a minor annoyance, however when away from home I have to turn on port forwarding from Google Wifi and get into it that way, reboot then its fixed.

Any ideas how to make it more reliable?