Naming zwave switches

How do i name zwave switches? Tried it with stopping Home Assistant and open zwave control panel but there is nowhere any save button

As you see i have 2 switch devices and i can not see whitch device is my desktop lamp and which is the switch for the curtains (by example).

If you mean the displayed name, you want to customize them and assign a friendly name or picture of your choice.

Also, any entity name changes can be done from within HA, using the Z-Wave menu under Configuration.

Nowere able to type anything

Type the new name in the box just above RENAME NODE then click RENAME NODE. You’ll need to restart Home Assistant after you’re done.


Nope dat dit not work, tried it severe times, even before i asked here in the forum.

38 the name stil Everspring AN 158 …

See above for the link, because I’m too lazy to repost that twice :wink:

Too bad there was no sensor name in configuration.yaml, tried it with the displayed name and at the next row friendly_name … checked configuration said Ok in green but with restarting, even Samba was not working so no connection possible with configuration.yaml
I must write again hassbian installing ssh, installing Samba, renaming password etc (i did it about 8 times the last 5 days since my first meeting with Home Assistant 5 day’s ago).

Is someone else who gave Zwave modules a different name (probably will not be Everspring) but if I first know how to put these modules in .yaml.

Can you not SSH on to your host? What if you hook up a keyboard and TV/monitor?

Changes to customize.yaml can be reloaded live, as with groups, scripts, and automations. Look in the Configuration menu, under General. For reference, since it’s possible you’re not taking the time to read the documentation, the format in configuration.yaml is:

  friendly_name: My friendly name

That’s what I read that page, but I’m looking for the real name of the Everspring, because it’s obviously wrong. That can be a capital letter, a line between the text, everything is possible, only one error is required. If that Everspring is somewhere in one of the configuration files, you can literally take it over. But also in the swave configuration, it can not be found. I just took over the name as it was visible on the screen (at the top of the icons is the full name)

I dit this in configuration.yaml

switch.Everspring AN158 Plug-in Meter Appliance Module Power
friendly_Name: Zwave-switch1

Probably the spaces should be out or need Module off, or module must be replaced for switch, there are plenty of options, but how do I get there?
That is not in the documentation.

1 Like

Guys I’ve addressed it differently, not the right way, but i see no other way : I’ve opened the switch modules myself and connected the chip to an interface, the string name was found. This adapted. What will be the effect of replacing the other everspring modules? I still have to wait. But for now i can see the difference between the switches on the screen


It is, you put the entity id in there. Not the friendly name it displays. That’s the same name you’d use in the automation, or anything else. That’s the name you find by clicking on the name in the dashboard, and looking at new entity id.