NanoMote Quad

Please help. After more than a bit of trial and error I was able to get NanoMote Quad connected. Now that it’s connected as a node in the Z-Wave network, I’m at a loss of how to get it to do anything. I really want to set up some scenes for others in my house so they don’t have to grab phones or talk to Siri. Nothing fancy but I can’t seem to find it when creating Automations. Here’s what I get in the logs.

2020-05-20 15:13:22.357 Info, Node003, Received Central Scene set from node 3: scene id=2 in 7680 seconds. Sending event notification.
2020-05-20 15:13:22.357 Detail, Node003, Initial read of value
2020-05-20 15:13:22.357 Detail, Node003, Notification: ValueChanged
2020-05-20 15:13:22.637 Detail, Node003, Received: 0x01, 0x0b, 0x00, 0x04, 0x00, 0x03, 0x05, 0x5b, 0x03, 0x16, 0x80, 0x03, 0x3b

Any help is much appreciated.

Instructions for how to enable central scene support for that and other devices are here.

Thanks. I made the change and restarted as per the instructions but now it’s listing as two nodes and both are ‘initializing’. Any thoughts on how to proceed?

Are you getting events as described?

It took longer than expected going through the query stages. I’m seeing this in OZW_Log.txt which looks like a good thing.

2020-05-22 21:21:47.852 Info, Node003, Received Central Scene set from node 3: scene id=4 in 7680 seconds. Sending event notification.
2020-05-22 21:21:47.852 Detail, Node003, Refreshed Value: old value=7680, new value=7680, type=int
2020-05-22 21:21:47.852 Detail, Node003, Changes to this value are not verified
2020-05-22 21:21:47.852 Detail, Node003, Notification: ValueChanged

I’ve made the changes to enable central scene support but now I’m not sure where to go from here. I see that the instructions have an example of:

'“event_type”: “zwave.scene_activated”,
“data”: {
“entity_id”: “zwave.nanomote”,
“scene_id”: 2,
“scene_data”: 7680

but I’m honestly not sure what to do with that.

Thanks again for your time on this.

1 Like

There are examples elsewhere on that page that show you how to trigger on scenes. Here’s one

- id: '1234567890'
  alias: Double-press Button 2 to toggle all lights
  - platform: event
    event_type: zwave.scene_activated
      node_id: 7
      scene_id: 2
      scene_data: 3
  condition: []
  - data:
    service: light.toggle
      entity_id: group.all_lights

and here’s one for my Wallmote Quad:

- id: Wallmote Duo Button 1
  alias: Wallmote Duo Button 1
  initial_state: true
    - platform: event
      event_type: zwave.scene_activated
        entity_id: zwave.fr_wallmote_duo
        scene_id: 1
        scene_data: 0
    - data:
      service: homeassistant.toggle

I have added my NanoMote Quad to Hassio, but when I attempt to include it in an Automation I have the option to use the battery status as a trigger. I edit the Command Class “91” information as shown in the link above for this specific device, but that made no difference.

What am I missing? Do not all devices work with automations? Does this only work with a script (or scenes or whatever automations replaces? I am new to this)?

1 Like

Hey @bleonard79 - I struggled getting mine setup also and didn’t find the help that useful.
Eventually got it working… Tips that helped me.

  • When editing zwcfg* file, make sure home-assistant is stopped. Otherwise you change will be overwritten.
  • Rob’s example was useful for helping get the format of the scene correctly. Thank you Rob.
  • However I first needed to see things were talking and get the right names.
    • in terminal, tail -f OZW_Log.txt to see that zwave events are firing.
    • After setting id 91 with the relevant details I was seeing this:
2020-12-22 21:34:52.283 Info, Node002, Received Central Scene set from node 2: scene id=3 in 0 seconds. Sending event notification.
2020-12-22 21:34:52.283 Detail, Node002, Refreshed Value: old value=0, new value=0, type=int
2020-12-22 21:34:52.283 Detail, Node002, Changes to this value are not verified
2020-12-22 21:34:52.283 Detail, Node002, Notification: ValueChanged
  • I then went to developer tools in home assistant UI and under ‘events’ listened to *. Here I saw my event was being received
    "event_type": "zwave.scene_activated",
    "data": {
        "entity_id": "zwave.aeon_labs_zw130_wallmote_quad",
        "node_id": 2,
        "scene_id": 1,
        "scene_data": 0
  • (You can change the listener to just zwave.scene_activated events now we’ve got them coming through
  • Finally I had the details I need to setup up my automation. I did this via the UI and the following trigger worked for me!
entity_id: zwave.aeon_labs_zw130_wallmote_quad
node_id: 2
scene_id: 1
scene_data: 0

Hope that helps you.

1 Like

For those using Zwave js and the zwavejs2mqtt addon, after adding the device to your network, automation triggers on button activity can be set from zwave_js_event events.trigger with conditions from event properties.

  - platform: event
    event_type: zwave_js_event
  condition: []
  - choose:
    - conditions:
      - condition: template
        value_template: {{ == ''002'' }}