Native Alexa scene support from Amazon

It seems that Amazon now has scene support:

> Today we are happy to announce the support for scenes, a new feature in Alexa skills developed with the Smart Home Skill API. With scenes, customers can issue a single voice command to an Alexa-enabled device such as the Amazon Echo or Echo Dot to set a predefined configuration of one or more devices to a desired state. For example, a customer could say, “Alexa, turn on bedtime” resulting with specific lights turning off, a bedroom light changing color to a low-lit orange-hue, a ceiling fan turned on, and the temperature changed to an ideal setting for sleep.

As I don’t own a Echo yet (but will get mine next week) I can’t judge in which this is super helpfull but curious to hear your opinions.


I own (2) of them and I’m really excited to see this feature. I’d love to know what will be involved in getting Alexa to recognize HA scenes?

Unless I am mistaken (haven’t tried it) this is already possible with Hue Emulation …

Using Haaska you could utter “Alexa, activate [scene name] scene.” and you were off and running. Interested to see the impact on utterance update/changes and handling of scenes now that Echo is jumping into this end of the pool.

Any update on this? Currently I use the emulated hue method but I have to say “Alexa, turn on goodnight”. It’s not a big deal but for family members, it would be easier for them to say “Alexa, goodnight”. Is this something that could be done eventually? Or would I have to use the more complicated build my own skill method?

I don’t think that this syntax will be possible. The syntax will still be “turn on”. When you set up the Alexa component, it actually gets a bit wordier, but more conversational. Like, I use “Alexa, ask Home Assistant to wake up Nora” and the lights go on in her room. So you’re saddled with “Alexa, ask [name you choose] …”

You’re right! I guess I’ll stick with my current setup. Thanks

I am tying to do this but cant get it to work. I have the scenes set up and an automation to turn them on at certain times but can’t get it to work with the echo. How did you configure this?

Here’s what I did. Note: I did not expose everything by default, just used the customize area for the scene I have called “scene.goodnight”

  host_ip: your_IP_address
  listen_port: 8300
    - script
    - scene
  expose_by_default: false

Then add this to your customize section:

    emulated_hue: true
    emulated_hue_name: "Goodnight"

Thanks for the help that worked. The only problem I am having is after I say “Alexa, turn on goodnight” it will turn on goodnight and then say “the device is not responding and I should check the network connection and power supply” but it did work. Am I missing something?

I think is solved in next release

1 Like