Navigating to specific page from Tasker

Hi there,

I’m using Tasker to launch the companion app based on various conditions. I can’t seem to find a way to navigate to a specific page on launch, whatever I try in the data field, it always loads the default page.

Is there a way to launch to a specific page?

I’ve also tried this with a clickAction in a notification, but can only get the default page to load.

Thanks!

Screenshot_20200527-072713|389x500

Are you using tasker to click on a notification? If so make sure you are updated to the latest version and check the docs to make sure the yaml is right. You can also use actionable notification to do the same thing too. You won’t be able to use tasker to launch a specific page like that because the app was not designed to do that. The app is really just a webview in that respect.

I was hoping to use Tasker to launch the app on a condition, navigation to a specific page. Thanks for clarifying that isn’t an option, so that I don’t keep pulling my hair out :joy:

I have tried to click on a notification with the clickAction specifying which page to navigate to, but only get the default page no matter what I try.

Can you confirm that you can navigate to a specific page in the companion app via clicking a notification?

Thanks

Yup it works for me, make sure you have it setup properly: https://companion.home-assistant.io/docs/notifications/notifications-basic/#notification-click-action

If its not working you may need to start fresh with the android app, its possible other features are not working either: https://companion.home-assistant.io/docs/troubleshooting/faqs#starting-fresh-with-the-android-app

Thanks mate, will give it another go and report back. Cheers

I have the latest HA install, latest version of the companion app, but still can’t get this to work. I have also followed the instructions to clear storage, remove integration, etc.

If the clickAction contains the full URL, it loads Chrome with the intended page. If the clickAction contains, for example, /lovelace/keypad, it loads the companion app with the default page, not the keypad page.

Am I missing something?

I just tested this in the services tab and it worked for me, my path set in lovelace is printers

message: printer
data:
  clickAction: /lovelace/printers

I have tried that previously, and now again. A notification pops up, I click on it, but still cannot get to the intended page, only default.

Is there any way to troubleshoot this?

Thanks

Check that Android system webview is up to date

No luck unfortunately :cry:

Can you share the Lovelace code for the path?

what device is this? its very strange its not working for you

OnePlus 7. Very strange indeed!

I had this same issue yesterday. @dshokouhi suggestions worked for me though.
This is what I did exactly:

  • Deleted the Mobile App instance for my phone from Integrations
  • Logged out of the Companion app.
  • Cleared app cache
  • Cleared app data
  • Uninstalled and reinstalled app

For some reason it took a few minutes before any of my test notifications came through…but they all came flying in at once and they all worked as expected. I probably took more steps than what was needed but I didn’t want to have to try more than once and deal with the possibility of multiple Inegrations/entities for my one phone (happened with a much older version of the app and was frustrating to fix).

Thanks for replying. I have just tried that, amongst everything else suggested, yet the default page loads every single. To say it’s frustrating is an understatement, but it must he something particular to my device.

Is there a way to debug this at all?

Thanks

I’m seeing the same behaviour with clickAction on two Pixel 3s.

Thank you for the feedback. I thought I was going crazy :joy:

@dshokouhi, @stipex

I received an Android webview update from the Play Store to v83.0.4103.96 this morning and after a reboot clickAction now behaves as designed :smiley:

Note: This is on a Pixel 3 running the Android 10 5 June 2020 version Build QQ3A.200605.001 with Play Services v20.18.17

EDIT I’m wrong. First test worked beautifully and took me to my hidden garage camera lovelace view. Every subsequent test simply launches back to that view. Dammit.

Very frustrating. Mine only ever loads the default view. Is there any way to troubleshoot this?