Neato botvac connected doesn't start

Hi there,

I’m rather new with hassio but I’m already in love.
I have a question / issue with my Neato Botvac D5 Connected, when i try to start cleaning, the robot makes a noise but then does nothing. I’ve tried doing it with IFTTT (action “start cleaning”) and it works perfect. Because I can see the status, battery, surface area cleaned, last cleaned and even the “camera” (map) I figure I must be doing something right :laughing:

In my configuration.yaml I have this:

# Components / Devices
  username: !my-user-email
  password: !my-user-password

and also this:

  - platform: template
    # Neato Dusty Vacuum
        value_template: 'Dusty: {{ states.vacuum.dusty.attributes.status }}'
        value_template: '{{ as_timestamp(states.vacuum.dusty.attributes.clean_start) | timestamp_custom("%d.%m") }}'
        value_template: '{{ states.vacuum.dusty.attributes.clean_area | int }}'
        unit_of_measurement: 'm²'
        value_template: '{{ states.vacuum.dusty.attributes.battery_level }}'
        icon_template: '{{ states.vacuum.dusty.attributes.battery_icon }}'
        unit_of_measurement: '%'

and this

      # Start/Pause
      - type: icon
        icon: mdi:play-pause
        tap_action: call-service
        service: script.vacuum_toggle

and this in my scripts

  alias: Vacuum Start/Pause
  - service: vacuum.start
      entity_id: vacuum.dusty
  - condition: state
    state: cleaning
    entity_id: vacuum.dusty
      seconds: 3
  - service: vacuum.pause
      entity_id: vacuum.dusty

See video for the sound the robot makes. It recieves “something” but my best bet is that it doesn’t recieve anything it understands.

to debug i tried making a simple entity-button but it seems it doesn’t want to remember my “service”

entity: vacuum.dusty
show_icon: true
show_name: true
  action: call-service
  service: 'vacuum.start'
type: entity-button

then i save and re-open and it shows an empty “service”
(i’ve also tried service: vacuum.start-pause)

entity: vacuum.dusty
show_icon: true
show_name: true
  action: call-service
  service: ''
type: entity-button

I’m lost here :confused:

thanks in advance!

Do you get a message when you open the app?

I have this issue infrequently and when I open the app it says the vacuum failed to retrieve the stored persistent map. Do you have a persistent map?

For me, this isn’t a HA issue, as the native Neato app does it too.

No message here.
Neato app and IFTTT widget work perfect.
I’m guessing you mean the no-go lines map?
I don’t use that. Is that the problem?

I read somewhere hassio uses the no go lines map as default so my guess is that that is the issue.
I tried service to test but it sais my jason is invalid. Any clues?

EDIT: It needed a comma after each but the last rule :smiley:

  "entity_id": "vacuum.dusty",
  "mode": 2,
  "category": 2

Yeah I meant the no go lines map. As you already found it seems to default to it.