Nedis Smartlife WiFi Smart Plug (WIFIP130FWT) not compatible?

I recently bought a pair of Nedis Smartlife WiFi Smart Plug (WIFIP130FWT) since I got the impression that these should work in Home Assistant via the Tuya Integration and choosing Smart Life account.

But when I try to enter the same username and password as I use in the Android app, I just get an error saying “Invalid authentication”
What can cause this?
Are there different types of Smart Life integrations?
Will we see support for this hardware?

One link to the smart plug:

Thank you.
And Happy New year :slight_smile:

i had similar issue… yöu should choose “Tuya” not “Smart life”… i tought also that “tyua” is header and “smartlife” type

HI. Thanks for replying.
I have tried all combinations there is.
I have also tried both username and email address.
But all combinations still says " Invalid authentication"


I had the same issue but with a Nedia Wifi Smart Plug WIFIIPO120FWT (Outdoor Plug). I eventually got it working by giving up on the NedisSmartLife App to register the devices as it doesn’t seem to be supported in the Tuya Integration, (The SmartLife account option in home assistant, is a different app to the NedisSmartLife version).

Anyway, I reset the devices and used the Tuya App instead to register devices on my phone, then when I installed the Tuya Integration I selected Tuya account, it worked directly!

Hope that helps


This worked like a charm.
Thank you very much! :slight_smile:

I have bought a Nedis WIFIP120FWT Wi-Fi Smart Plug with power monitor. Got it working via the Tuya Smart app and the Tuya integration as @tfi_friday suggested. I can only switch on/off. Voltage, current and consumption are not available as entities in Home Assistant.

Yep, same issue for me regarding the additional entities, but was just glad I could get the device on/off.

Tried the same with no success; removed plug from Nedis app and tried with Tuya, but it fails continuosly in pairing as App cannot find the plug. Not sure is it because my wifi has both 2.4Ghz and 5 Ghz, and my mobile e.g. camps to 5G always. But it did work with Nedis App OK. I had similar WiFi issue with another Deltaco plug which I already returned.
2. Then some post suggested another “Smart Life” App to pair, but that was provided by Volcano, not Tuya.
3. And final issue in HA was that Tuya requires also Iot access ID/access secret. I managed to create those in Tuya development cloud but giving those resulted yat another access failure

Any success getting Voltage, Current and Consumption from the Smart Plug?

What kind off 230 Volt plug’s ARE supported with Home-assistant?
Offcourse preferably niceprice…

I would like be able to switch on/of a networked device remotely that doesn’t have its own Wake On Lan.
I thought maybe there is some hardware that is supported with HA, the same as my ikea lights