Need a more solid solution

I have small Z-Wave network and am really struggling with door sensors no longer communicating from time to time. The furthest sensor is 25’ away through 2 walls, the other is 10’ LOS. Everything works great for a month or so then furthest one starts acting up. Oddly, if I replace the batteries in the sensor it is OK again for another month or so. The battery level is never below 90% and I can even swap the battery out with another sensor and works ok as well for another month or so.

There are 3 ideas I have come up with that may be the issue.

  1. The radios in the sensors suck
  2. The radio in the Z-Wave stick sucks
  3. Interference around the cables or USB ports

My setup is as follows:

Z-Wave controller - UZB by Z-Wave.Me on USB 3.0 with 3’ extension
NVME controller on the other USB 3.0
Door sensors- WADWAZ-1 by Nortek Security & Control LLC

Have any of you had negative experiences with either the same controller or sensors? Any issues with interference using both USB 3.0 ports, 1 for SSD and the other for Z-Wave? Any other ideas? With Matter not too far out, I don’t want to just rip everything out and start over due to the financial impact.


You need more devices that are not battery powered(plug, dimmer,…) to get strong mesh.

I have found Z-wave to be highly reliable, but occasionally painfully slow. However, I have about 50 devices and only one is battery powered, so I have a strong mesh.

If it’s a software solution, you might try using the command on the device when it isn’t responding to see if that wakes it up. (If it does, you can make an automation that pings it every night, for example.)

Otherwise I would agree with Jose: try getting one or two zwave plugs and putting them between the device and the hub to see if a stronger network helps.

That is brilliant! I was thinking about a range extender a few weeks ago but having a functional device to extend range/create a mesh makes a hell of a lot of sense. I have quite a few WiFi plugs I can swap out and repurpose.


I did not realize there is ping functionality via the command line. I will look into that today to validate the range idea.


I just realized that is a service, not a command line. Anyway, I am not sure really how to use it. I have run it from Dev Tools but I am not sure what I am looking at as far as results. Am I missing something?

If you go to the ZwaveJS add-on and click on the log you should see something like this:
2021-12-16T17:20:07.218Z CNTRLR « [Node 026] ping successful

If you don’t see that then the device can’t be reached on the network. However, since it is battery it might take a while to respond.

Didn’t think about the logs. I get this" [Node 021] ping failed: The node is asleep (ZW0202)" which makes sense. I enabled the “status” entities so I can monitor and after reviewing history they show asleep then they do something for 1 second every hour where status goes null. I don’t think they can be pinged constantly since they are battery powered.

I learned a ton from this thread, I really appreciate the time. I went ahead and bought 1 Z-Wave plug to put theory to the test but I think it will work.

Good luck! I’ve found Zwave to be more reliable than Zigbee on either ZHA or Deconz, but sometimes inexplicably slow.

A few things one can do to try to improve a slow Zwave network are:

  1. Check all your power monitoring devices and either turn off the reports or extend the delay between reports. For example my home energy meter supports 3 groups so I split the many values reported between the 3 groups and set them at increasing intervals so they don’t all happen at the same time.
  2. Check any motion sensors, especially the ones with other sensors (ie 4-in1 zooz multi sensor) as they can cause trouble by being very chatty
  3. When automating, avoid sending unnecessary commands. I always check the status of what I am about to control to ensure its state actually needs to be changed. (ie Motion turns light on/off but light may already be on so why send the command again)
  4. Ensure you have a solid mesh network by evenly distributing wired zwave devices so that battery operated zwave sensors are in close proximity to a repeater. If your mesh is made of 500/700 series devices then you have Network Wide Inclusion therefore pair the sensors in the location you will use them so they start off with the proper route. Enrolling them near the hub (and far from their final resting point) may result in them not having a good route back to the hub… at least for a while or until you do a network heal. I’ve had mixed success but it is what I read should be done… (and I am only now getting rid of 100% of non plus devices).
  5. Get rid of any non 500 or 700 series devices. Zwave plus is much faster, especially if you use encryption. Prior to Zwave Plus encryption was S0 and if I recall correctly it increases 2 or 3x the traffic.
  6. Unless you are forced to use S0 encryption (such as on older locks), don’t use it. Go unencrypted as it will be faster and the risk is likely negligible (those who fear someone breaking in… a thief will just break a window or kick in your door… they likely don’t even know what zwave is). With 500 or 700 series you can use S2 encryption which I believe has minimal additional burden (ie processing power)
  7. Spread the device load between zwave and zigbee if possible. I am currently at about 90 zwave and 90 zigbee. By reducing my zwave device count things have already gotten better. When picking what to migrate over consider that in-wall outlets often are either just on/off or have energy reporting along with on/off. These are good candidates to by swapped over to zigbee as they don’t have any fancy configuration options. Dimmers, on the other hand, often have a ton of configuration settings which seem to only exist on zwave devices, so for those I’d stick with zwave (this may change with Matter… no idea).

There is surely much more but I figured I’d share my findings as I too often have a slow network and have been spending time and money (by replacing devices with zigbee) to eliminate the issues. From what I read, even a single S0 device can slow your entire network down… and I have 3 old S0 locks so if that is true, I need to invest $600 in 3 new locks :frowning:

You want a minimum of 2 mains powered devices, and REALLY TRY to ensure they are ZWave Plus (Gen5) at the minimum. The benefit of ZWave Plus is that it will automatically repair the network, the best ZWave networks never ever use “Heal Network” which often causes more problems than it ever solves. The most stable network will be composed entirely of Gen5 or newer devices. Keep a look out for deals on ZWave light bulbs and plugs, that’s how I grew my network - Cheap ZWave Gen5 dimmable lightbulbs. My ZWave network happily spans across 3 buildings, and is rock stable.

The outlet I bought is Z-Wave Plus and I will look at buying another one. My home is only 750 Sq/Ft, so I don’t need much, just to get through a couple walls I guess.

So, with Z-Wave Plus, is there anything I will need to do after it is plugged in for the sensors nearest to it to start using it? The sensors I am sure are not Plus, but the Z-Wave stick is.

I’m not actually sure, I don’t think so. But all my sensors are ZWave+ the benefit of ZWave+ is that of the route a device tries to take back to the controller has vanished - it broadcasts essentially a “help me!” Message and other ZWave+ nodes that can hear it will respond, so they can organise a new route back to the controller, without the controller having to be instructed to do anything at all. It’s basically what ZWave was always meant to be, the network actually repairs itself without intervention. The reason you are advised against healing a network with ZWave+ nodes on it, is because typically the controller will instruct devices to use what it considers to be the shortest route back to the controller, but that’s not necessarily the BEST route, once interference etc is taken in to account. It’s best to let a ZWave+ network take care of itself :+1:

I got the new plug installed and bingo, sensor in the back of the house are now working.

Oddly, if I move the plug, it loses its ZWave integration. I try to exclude it and it won’t. I add a new device and it shows up leaving me with an orphan ID. I did this twice and the same thing happened. Cheap plug perhaps?

Anyway, happy it is working, thanks to all who replied.

In the end, I suspect the Z-Wave controller to be pretty crappy and plan to upgrade to Aeotec dual radio. I leave Zigbee to Alexa but wouldn’t mind having options.