Need assistance with install

I wonder if someone could lend a hand.
I’ve spent 3 evenings trying to install HA on a Raspberry Pi3 with absolutely no luck.
During this time, I’ve tried using the All In One install 3 times and every time the install just dies at this point:

[localhost] out: /srv/hass/src/open-zwave-control-panel/webserver.cpp:338: warning: the use of mktemp' is dangerous, better use mkstemp’ or `mkdtemp’
[localhost] out:
Connection to closed by remote host.

Someone suggested that I then try to use the HASSbian image for the Pi and although the install goes thought without any issues, when I try to add the Z-wave function, it tells me that there is a problem with my configuration. Looking at the log, it tells me that I am missing the python Open Zwave module, but I had clearly installed it from the instruction page without any problems. I have done this build twice so far.

Although somewhat of a noob, I would say that I have a good amount of experience installing software on a raspberry. I’ve done several install of different applications, my late was to install OpenHab and all worked well.

Not sure if the installs have been tested recently or I’m missing something, but at this point, I am wondering if someone would have a basic working image of HA with Z-Wave that they would be willing to share. Would really like to integrate this platform with ISY controller.


Just guessing - be sure you’re not trying to install as root. That’ll definitely cause troubles. Install as “pi”.

1 Like

Thanks, I really appreciate your reply.
For the AIO install i just do the wget command no sudo. For the raspberry image, I just copy the card and boot from it, when installing wave, it seems like some commands require me to use sudo. I’ve tried my 6th attempt today in getting this to work and no luck. I am not understanding why I’m having such a hard time. Also wondering why there is no comments from the developer of the AIO install, I see others that are having the same issue.

I’d really like to get this working, but If I can’t I’ll just need to move along and try something else. Thanks again

I can’t help with zwave but when I need a program with a HASSbian install, I need to make sure I’m in virtualenv with these commands before installing the python zwave.

sudo su -s /bin/bash homeassistant
source /srv/homeassistant/bin/activate

my prompt looks like this after

(homeassistant) homeassistant@raspberrypi:/home/pi $

then I can install python zwave

It’s been a long time since I did my AIO install, but I don’t think I had to install anything separately. Just that single line install that includes the wget and install in one command. Wait a while and it does everything on its own.

wget -Nnv && bash

Thanks to both for your assistance, I am trying the AIO install once more to see if I am going to get further, this time around I haven’t made any changes to the Jessie install except to expand the filesystem and keeping the password unchanged. If this doesn’t work, I’ll try RobDYI’s method although I had done something similar to this in the past but willing to try it again, I really would love to get this going.

I did a test install of the AIO a few weeks ago. I usually find my ssh session seems to have frozen but it’s still going in the background. Maybe because I have slow internet. I just walk away for a few hours before I log in with a new window to reboot. I used the full Jessie image from September.

Thanks BarryHampants and all,
Also marking this as a reference for others that may experience the same issue.
This seems like it’s more of a disconnect than an actual abend of the install.
Just be patient and let it run for some time. My installation from the AIO finally finished. All is well.

I seem to have similar issues with my Raspberry Pi 3 what I ended up doing was just doing the manual installation Raspberry Pi and that worked out just fine.