Need clerifiacation on Z-Wave JS to MQTT

If I run ZwaveJS2MQTT on supervised Rpi. Should I then be abled to configure that one so I can connect from another HA installation on a VM (supervised) without using MQTT, but with the integration component in HA on my VM installation

I may be having a bit of trouble understanding what you are asking but…

If you have a running zwavejs server running on your network (installed via HA Supervisor in your case) then you can connect to that server from any other machine on your network that can interact with that server.

So you can have as many instances of HA running the zwavejs integration as you want on your network.

I have zwavejs2mqtt installed in a standalone docker container (not installed via the supervisor add-on) and I have the integration set up on two different HA instances using that same zwavejs server.

The add-on would work exactly the same.

I hope that’s what you are asking.

Thx That was my questian. But for some reason I dont get it to work :frowning:

RPI with Ha installed (supervised) and zwarejs2Mqtt.
Second HA (my main system) on a VM in hyper-v.
My HA on VM is not able to connect to my rpi via zwavejs intergration.
Any ide what to look in to?

It could be a couple of things.

Make sure you have the websocket server enabled in zwavejs2mqtt.

And that you are using the correct server address/port in HA.

And that the server ip is accessible by the devices in your network.

Error on my HA Server when trying to add intergration
image

And my RPI with zwave2mqtt has this configuration.

If a make a port scan on my rpi I can not see that port 3000 available.
Is there anyconfiguration needed to make it available on the rpi?

Btw the Z-Wave-JS intergration works localy on my RPI

I, just read this on homeassistant page-

and it says

CAN I RUN Z-WAVE JS TO MQTT ONLY FOR THE CONTROL PANEL AND NOTHING ELSE?

Sure, in the settings of zwavejs2mqtt, make sure to enable “WS Server” and disable “Gateway”.
So turned off MQTT gateway but no luck there :cry:

restarted zwave2mqtt and kinda looks good

are you using the ip_address:port of the zwavejs2mqtt machine in the config?

is the zwavejs2mqtt server that is running installed via a HA add-on, docker container or some other way?

I think there was some strangeness when running the add-on and what host name you had to put in there but with either the add-on or the docker install I’m pretty sure that the ip:port works for either of those.

I have tried both ip and Dns name. My Rpi is a Home Assistant Operating System install with supervisor and my Z-wave stick is a Aeotech and zwavejs2mqtt serve is installed via addon. If I make Nmap scan on my rpi I can not see port 3000 published. The local zwaveJS intergration works so I guess HA can access the port internally on docker network. Do I need to make some config changes tp get the port published? or use Nginx addon to make it show up on host network?

Make sure you’ve mapped the port with docker.

Example compose yaml:

pi@friday:~/zwavejs2mqtt $ cat docker-compose.yml
version: '3'
services:
  zwavejs2mqtt:
    container_name: zwavejs2mqtt
    image: zwavejs/zwavejs2mqtt:latest
    restart: always
    tty: true
    stop_signal: SIGINT
    devices:
      - '/dev/serial/by-id/usb-0658_0200-if00:/dev/zwave'
    volumes:
      - /home/pi/.zwavejs_cache/store:/usr/src/app/store
    ports:
      - '8091:8091' # port for web interface
      - '3000:3000' # port for zwave-js websocket server

TBH, I’m not sure. I don’t use HA OS at all.

Hopefully someone who does can chime in and help you out.

Oh HAOS, make sure in the addon config you have the port 3000 enabled, it’s disabled by default.

2 Likes

Hi, Thats probably it

But what do I need to write there tried Enable, Enabled, Yes but it Just goes back to Disabled. Tried to find some documentation but no luck there.
thx
/Håkan

enter 3000

1 Like

Of course , Now it works. Thanks alot for helping me

1 Like