Need configuration advice for Aeotec Trisensor ZWA005

Tags: #<Tag:0x00007f3f2e9cc6a0>

I have begun to establish a Z-wave mesh network with HA, running Hassio on an RP3. I am using the Aeotec USB Z-stick Gen 5 and believe I have the network up and running successfully, but am struggling to get the Aeotec Trisensor ZWA005 running correctly. After initial configuration, and getting values, it just stopped reporting.

My only other Z-wave devices are Aeotec and all are working as expected except for the Trisensor. See all of my Z-wave nodes in this screenshot from Z-wave Control Panel:

nodes

The nodes were not added as “secure” nodes (if that matters). At this moment you will see that my Trisensor is showing “CacheLoad”. I have seen where others mention needing to pull and reinsert the battery to get this device to start reporting again, but I have not tried that yet because I don’t see that as a good solution.

Here are the entities associated with Node4. Initially they reported values and value changes, but just stopped.
node_entities

Things I have tried include manually waking up the device, ensuring the Binary Sensor Report is enabled, restarting the network, heal, test node, test network … pretty much every option in the Z-wave control panel … and also restarted Home Assistant.

What I have not done so far, because I don’t know that much about Z-wave yet, are changing various config’ options.

My questions, to anyone who would be so kind as to respond:

  • If you have had success with this device, what did you have to do? Are there specific configuration for the device or controller that I should try?

  • I am assuming that “burlar” is the motion sensor … is that right, or am I missing something?

  • I included my new devices as regular nodes (not secure) … should that matter?

  • Maybe this device is not the best one for me … any other sensors that you would recommend with my Hassio/Z-stick configuration?

Thanks in advance for any assistance.

Update: The luminance sensor just showed an update after not changing for almost 12 hours, but temperature and burglar are still not changing. I am hoping there is something simple in the node configuration (maybe wake interval, or polling, or something?) that someone with more experience could recommend. All node configuration settings are at the defaults. Binary Sensor Report is enabled.

I resolved my problem by simply doing a factory reset by pushing the button on the device (per the vendor support doc’. All is now working as expected with binary sensor DISABLED. I should have mentioned that I was experiencing my issues with that setting ENABLED, which is recommended by Aeotec tech support (I opened a ticket with them), and various post in the HASS community. After the factory reset, the defaults and binary sensor report DISABLED worked for me. So the takeaway for anyone reading this that is having issues, is to try the reset, and binary sensor report may not need to be enabled.

1 Like

Thank you for the advice. I am currently experiencing the same problems with the sensor.

I was able to solve this similar issue (being stuck on query stage Initialization / Probe) by first removing the device completely, then adding it as a secure device and pressing the action button several times til it’s red.

  • I could not “remove failed device” because it was stuck in initialization so I manually set its state to is_failed: true, which enabled this button. I removed the device and rebooted the system.
  • Before adding the node, I ssh’d into the system and did a tail -f OZW_log.txt so I could monitor the z-wave activity while performing commands via the UI
  • I clicked add secure node, then held the action button the the TriSensor for 2 seconds (until the LED turns red). This seem to begin initialization but puts the device to sleep.
  • I waited until there was no more activity from this node, then again held the action until red, the query stage move up another
  • Repeat the previous step until the query stage is completed

This is with the factory defaults

Hope this helps!

1 Like