Need Guidance on Virtual Box USB Devices

Hey everyone, thanks for reading and any input.

I am attempting to Install my first HA. I have downloaded Mint and updated. Virtual box, updated, and installed the package that would allow USB 3.0.

This is to allow the HA virtual box download to access a Conbee II and Aeotec Z-wave USB devices. Both list just fine inside Mint (lsusb command shows them listed). However Virtual Box doesn’t show any USB devices being passed to HA.

Not many resources that point to an answer save for one that suggests that I must install the Guest Additions onto the guest. I use Hyper-V a lot so this makes sense to me but my foray into Linux has run into this snag; anyone know if this is correct and if so, how do I get the HA virtual box package to install the guest additions?


Within virtualbox under the VM’s settings for “USB”, have you ticked the “dresden elektronik” filter to allow the VM to have access to the USB device? And also, within the VM instance (eg. click Show to open it), under the Devices > USB menu it should also be ticked (this should be done automatically, but if there’s a problem during boot it can become unticked.

Also, from memory, Guest Additions provides USB 3, whereas the conbee is only USB 2 (I think), so probably doesn’t make much difference.

Running the lsusb -v to pull as much information as possible, I created a filter using the vendor ID and device id. Did not show up for USB 1, 2, or 3.

Would there be a barrier between Linux and VirtualBox? Permissions, or something?

Found the solution, my instincts on permissions lead me down the correct path.

“sudo gpasswd -a yourusername vboxusers”

The above was required before the USB devices were handed over to virtual box.

Solved! Thanks Michael Blight!

What user / pw do you use with this command and where / how do you execute it from ssh? Can you provide me with the steps?