Need help flashing Wemos D1 mini

Working on adding a DHT 22 connected to a Wemos D1 mini as described in this article but no matter what I try the serial device is not detected for flashing. First connected it to my Mac via a USB cable and tried to flash via Chrome browser but it couldn’t find a serial device. Next I connected the device to a USB port on my Yellow but had the same problem. I can see a blue LED flash a couple of times on the D1 mini when the USB cable is plugged in.

Gpio0 to ground.

Sorry. I don’t have a clue what your reply means. Are you saying to jump D0 to GND on the D1 mini?

I am connecting the D1 mini via usb cable without a serial adapter.

I assume if you followed that guide, you have installed the ESPHome add-on on your HA instance?

When you go to install the code, you should be present with four options. The easiest is “Plug into computer running ESPHome dashboard”, which is your HA server. Clicking that should display a list of ports with devices connected and your D1 Mini should appear there.

It just displays a set of eyeballs and a message that no device is found.

I reckon you have either a faulty cable or a faulty ESP.

I’ve tried 2 cables so it’s probably not that. Was finally able to get it flashed by hooking up an FTDI adapter using a pinout for the D1 I found on ESPhome. Seems to be working at least for now. No clue why this worked.

The only problem I see is that temps are way low after a reboot. There was a comment in the article I linked that it is necessary to run “update all” in ESPHome after every boot of the device to correct this. Any ideas how to fix it?

Before trying that, try specifying the actual DHT model in your yaml, rather than relying on auto detection.

Something like this-

  - platform: dht
    pin: D2
    model: DHT22
      name: "Living Room Temperature"
      name: "Living Room Humidity"
    update_interval: 60s

Correct. I had a whole bunch of errors with incorrect and nonsensical temperatures until I hard coded all my sensors.

It may not be your issue but worth a try.

Looks like that fixed it. Thanks for the help,