Need Help getting Roomba password

Hi,

I just bought a Roomba j7+/Braava Jet M6 combo.

It recognized both of them in HA right away. I first tried to setup the Braava Jet and that went without any issues. When i tried to connect to the Roomba it can’t retrieve the password automatically and suggest to do it manually. This is where i run into problems.

I run HA directly on an intel NUC and i have no idea how to proceed from here. I looked at the 2 links they provide but i’m still not sure if i have to install something extra to retrieve the password or i should just be able to run a command somewhere.

Any help would be appreciated to point me in the right direction

I found this: GitHub - pschmitt/roombapy: Python program and library to control Wi-Fi enabled iRobot Roombas

after running the pip install roombapy command i can run the roomba-password command
It does give me a whole bunch of info, the last part being the password, but it’s empty?!?

So the command can connect to my Roomba, it get’s its hostname, blid, firmaware,… but for some reason the password is empty

What am i doing wrong?

I’ve tried so many different ways of pressing the button on the j7+ Roomba to see if i get a different result :frowning:
I get all the info except for the password. That string stays empty

Still hoping somebody managed to get the password of their Roomba this way and can explain to me what i’m doing wrong.

I just ran into this problem. It looks like some of the other libraries for Roomba have been updated to account for this. You need to download this library and run password.py with your cloud username and password. It will give you each device password.

Thanks for that! I now have my Roomba hooked up to HA

After spending WAY too much time getting this to work, here is how I solved the blank password issue. Hint: the big round button is not the HOME button…

Roomba I7 (Costco) solution:

  • Ensure the Roomba mobile app is NOT running on any mobile phone or HA instance - if the app is running somewhere you will get a connection refused error

  • Get on to the HA physical console - you should see a HA prompt. I swear I used to be able to do this from the web interface but that does not seem possible anymore. If someone knows how let me know how

  • Type the following and hit enter
    ○ login (this will get you into supervisor mode with a # prompt)
    ○ docker exec -it CONTAINER_NAME_OR_ID python -c ‘import roombapy.entry_points; roombapy.entry_points.password()’ ROOMBA_IP

  • On the above command change your CONTAINER_NAME_OR_ID name (mine is homeassistant) and the ROOMBA_IP to your device’s IP address

  • You will be instructed to press and hold the HOME button. The home button is NOT the big round button on the i7. If you press that you will get information back about the device but a blank password! If you press the Home button and hold on an i7, the blue ring will spin after a few seconds and you will hear a tone. Now press enter on the HA console and you will see a password that is not blank in the returned data.

  • Enter the really-long, case sensitive password in the integration setup - done!

I hope this helps someone to not spend too much time getting Roomba setup in HA.

2 Likes

Created an account to post here that this worked perfectly! and thank you!

You say the home button is “NOT the big round button on the i7”, so then which button is it?

No idea what they are talking about. I have an i7 and the big button is the home button.

I used the python script to get my pw. It’s pretty straight forward if you have python installed.