Need help installing to Armbian on Odroid C2 via Docker

Hi, I’m having trouble with installing Home-Assistant on an Odroid C2 via official Docker documentation. I’m a bit confused as I see there is a Raspberry Pi 3 (Raspbian) specific Docker release + the regular, which I assume is for x86. I’ve tried installing both, but am somehow messing this up. I’ve tried setting my config volume as /home/user/ha

Any tips or guidance greatly appreciated! Excited to try out Home-Assistant!

x86 won’t work on ARM devices

you need to look at ARM builds

Do you know if it is possible to use the Raspbian docker ARM build on Armbian? I’m unclear on how to get it working.

Using this Odroid H2 thread, I’ve switch over to the armhf-homeassistant Docker release.

When I start the contains it immediately exits. I’m trying to follow this guide and cannot figure out what I’m doing wrong.

docker start home-assistant

xxxxxxxxxxxx homeassistant/armhf-homeassistant “/bin/ pytho…” 2 minutes ago Exited (132) 36 seconds ago home-assistant

docker service logs home-assistant

Error response from daemon: This node is not a swarm manager. Use “docker swarm init” or “docker swarm join” to connect this node to swarm and try again.