Need help on tweaking the Assist audio configuration


I am using the Atom Echo as assistant and it works pretty well as long as I sit in front of the microphone. But at a distance of >1m I need to raise my voice to be understood. 2m and more: nothing works. Not real life usable… So I followed Troubleshooting Assist - Home Assistant but am stuck because I don’t find the place to add this config snippet of step 11:

   noise_suppression_level: 3
   auto_gain: 31dBFS
   volume_multiplier: 10.0

I run home assistant in a container so I cannot use the Add-on store and had to deviate a bit from the instructions. I have no trouble using vi to edit files in my config/ directory, but which file is it? It is not named in the docs :frowning:

In the ESPHome integration (is integration the same as add-on?) I do not see an Edit button or link to select as suggested in step 10.

Any help appreciated.

Ok, I just learned that integration and add-on is not the same and add-ons are not supported in containers.
But still, the ESPHome integration is working, can provide the assistant functionality. It should be possible to configure it somehow???

figured it out:

create another docker container, e.g. with this docker compose yaml:

version: '3.0'

    container_name: esphome
    image: esphome/esphome:stable
    restart: unless-stopped
      - "6052:6052/tcp"
      - TZ=Europe/Berlin
      - /share/Docker/esphome/config:/config
      - /etc/localtime:/etc/localtime:ro
    network_mode: host

The docker host path /share/Docker/esphome/config is good for my qnap containerstation, needs to be adapted to point where on the docker host the config should be stored.

Run the container and connect to http://your-docker-host:6052

Your esphome devices will show up there. After adopting them, their yaml config can be edited, the firmware recompiled with the changed config and an ota update initiated.

Valid settings for the yaml config can be looked up here: firmware/voice-assistant at main · esphome/firmware · GitHub