Need help reconnecting a device

I have a number of smart switches which have worked just fine since I put on new firmware, but I have just lost a device and I simply cannot make it join again.

I noticed the device being offline so I tried a lot of things, but nothing worked:

  • Restart home assistant.
  • Power cycle home assistant computer (which includes ZigBee coordinater).
  • Power cycle the smart switch.
  • Reset the smart switch (follow by searching for new devices in HA). Did this multiple times.
  • Turned off (no power) all other smart switches and reset smart again. This incidentally required my to power cycle the HA computer as it suddenly lost the coordinator (couldn’t talk with it, but it was there).
  • Tried to delete the device in HA and rejoining it.
  • Tried various ZHA Toolkit leave, join, rejoin, reinitialize.

Nothing worked.

When I reset the smart switch (or power cycle) it blinks for a few minutes and then stops blinking. I am not sure why it stops blinking.

How do I debug/fix this?
Any hints?


Using ZHA Toolkit, I made a backup of the Coordinator Data, an looking the the resulting nwk_backup.json file, I see the smart switch device present, but home assistant doesn’t know about it.

        "ieee_address": "xxx",
        "nwk_address": "2e0f",
        "is_child": false,
        "link_key": {
            "key": "yyy",
            "tx_counter": 4577,
            "rx_counter": 0

So I guess my task is to make the coordinator forget about the device? But how do I do that?

You could probably edit it out for the current json file. Be careful though, take a backup too.

The json file is just a copy/backup. Nothing will happen if I edit this file.

I don’t use ZHA, I use Z2M and there I have a backup yaml file and a current one. I guess the concept is different in ZHA then :slight_smile: