Need help restoring HA without internet connection

I am running Home Assistant on a Raspberry Pi 4. I was attempting to move my Pi server to a newly created VLAN. I went into Settings → System → Network → IP4 and proceeded to change the ip4 address to one in the new VLAN. I failed to check if there was a gateway. After the change I can no longer access my Home Assistant system with either the new or old ip address. I’m guessing the Pi thinks the gateway is and the device ip address is 192.168.50.x.

I need suggestions how to get my network configuration straightened out.

I used an hdmi cable from the Pi to my TV and connected a wireless keyboard. I powered up the Pi and got to an HA CLI screen. I managed to get to the underlying operating system and was looking for a configuration file that would have the network information. Does anyone know where this info is stored?

A second option would be to restore from backup. Can this be done from the HA CLI? If so how would I accomplish that.

Could I remove the micro sd card from the Pi and put it in a Windows machine to copy a backup file(s) to a current location? If so what O/S files should I copy and from where to where?

Any help/suggestions are greatly appreciated,

From the command line you can get and set network info:

Common tasks - Operating System - Home Assistant

ha network info
1 Like

Hi Mark,

Thanks for the feedback. I was able to do the ha network info and saw the update options. One example was ha network update eth0 --ipv4-method auto. When I tried that I got an error that eth0 didn’t exist. I then tried ha network update --ipv4-gateway and got an error saying that it expected 1 argument but got 0. I tried using quotes around the address with the same error I tried the method auto and also got the argument missing error. Obviously I had some kind of syntax error.

I really appreciated your quick response and suggestion.

On a different note after hitting myself on the head a few times I solved the problem. After I had changed the ip address in HA I modified my port forwarding for HA in my router. What I failed to do was modify the port on my switch for VLAN 50. It was still looking for traffic on VLAN 1. After changing the port and rebooting the Raspberry PI everything worked again,

Thanks again