Need help restoring local network access

I have home assistant installed in Oracle VM on a PC. I was trying to get the IPhone App working and mistakenly disabled local network access (where troubleshooting suggested to toggle access off and on). Now I can’t access Home Assistant on my browser. Dumb I know. I have several hours into setup so would appreciate help. I have access to “ha >” in VirtualBox.

To start

Open CMD and ping homeassistant.local -4

You’ll get an IP and results if it’s replying to the ping.

I am going to ask a possibly dumb question since I’ve never done this, but how did you “turn off” local network access?

Have you tried the IP of the Home Assistant server?

Can you connect with the iPhone app?

Hi Stephan,

In the Home Assistant App, go to Settings, then Network. If you then click on each of the two options (assuming your instance of HA is the same as mine). You are then presented with three options for each, one of which is disable. It even warned me that it was a little dangerous, but I clicked anyway. Ugh.

Hope that is useful.


Oops, I did not reply to all your questions.

Not sure how to access and interact with the IP, but am willing to try if you can guide me. I’m going to try pinging it this morning.

I am getting an error in the iPhone App. Was trying to troubleshoot that when I did this to myself.


I tried that and it didn’t work. In virtual machine I entered “network info” and can see IPV4 and IPV6 are disabled. Do you know what I enter to re-enable? it provides the IP address, not sure what to do with 0/23 at the end of the address. I will play around with it a bit.

Thank you!

Can you access HAOS console?

I can get to “ha >”

Hi, As your Iphone-stunt description doesn’t make sense to me ( You could have described what these various Options were (named) EDIT: I never had an Iphone :wink:
In HA-Console, try to type

ha core inf

and post the result

Or, just check if you even manage to enable SSL

to enable IPv4 try

net up eth(your nic-interface-name) --ipv4-method auto