Need help with configuration of Xplora watch integration

I’m trying to install the Home Assistant sensors for Xplora watch from here: But as a new Home Assistant user I get stuck. Does anyone have experience of using that integration?

I understand for new integrations to be included in Integrations - Home Assistant they have to use the configuration via the webGUI, so I have never really used configuration.yaml. And although I’ve tried to follow the instructions at nothing from Xplora appears anywhere, in order to use in automations.

Using File Editor, my /config/configuration.yaml currently looks like this:

# Loads default set of integrations. Do not remove.

# Text to speech
  - platform: google_translate

automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

  country_code: "+46"
  phonenumber: "07********"
  password: "***********"
  userlang: "sv-SE"
  timezone: "Europe/Stockholm"
  child_phonenumber: # optional & ignored if 'watch_id' is set
    - "07********"
    - "07********"
  types: # optional
    - "battery" 
    - "step_day"
    - "state"
    - "safezone"
    - "charging"
    - "silents"
    - "alarms"
    - "dt_watch"
  safezones: "show"
  scan_interval: 180
  tracker_scan_interval: 60
  - platform: xplora_watch
    name: "XPlora"

I have restarted after adding this to configuration.yaml. I suppose there must be something wrong with the configuration?

Check under Developer Tools → States and Under Entity Filter type Watch.
If averything works you should get following:

I canæt figure out how to get Watch to show Home / Away tough.

Thanks. I realized that the error was that I had the leading 0 in the children’s phone numbers. Removing that and it worked.

Although there are some other issues, like watch trackers not updating and battery level being set to -1. But there is the discussion at Issues · Ludy87/xplora_watch · GitHub too.

Sorry to jump on this but i’m having issues setting this up, i have tried setting it up through the UI but having no luck, I’ve added my details but its coming back as connection failed. I then tried through yaml but i’m getting;

Error setting up platform xplora_watch
20:06:51 – (ERROR) Notifications (custom integration)

Logger: homeassistant.components.notify
Source: custom_components/xplora_watch/
Integration: Notifications (documentation, issues)
First occurred: 20:06:51 (1 occurrences)
Last logged: 20:06:51

Error setting up platform xplora_watch

Traceback (most recent call last): File “/usr/src/homeassistant/homeassistant/components/notify/”, line 71, in async_setup_platform notify_service = await hass.async_add_executor_job( File “/usr/local/lib/python3.10/concurrent/futures/”, line 58, in run result = self.fn(*self.args, **self.kwargs) File “/config/custom_components/xplora_watch/”, line 24, in get_service coordinator: XploraDataUpdateCoordinator =[DOMAIN][(discovery_info or {})[CONF_ENTITY_ID]] KeyError: ‘entity_id’

My Yaml set up is below.


Any ideas?

I just got the X5 Play and installed the integration. Somehow I am only able to see the number of messages. All other entities are unknown. Anybody know how to solve this?

To set-up the integration i used the email authentication as phone number didn’t work: ‘Unknown error occurred’, not sure if that is part of my issue

Interestingly I can use all the message features, but nothing else. So no shutdown etc.