Need help with connecting to harmony hub

For the life of me I can’t get my Harmony Hub to show up in my HA install.

Things I’ve tried:

configuration.yaml has the discovery option in it. I tried enable - harmony but that just seems to stop everything from loading.

I tried to manually load it with


  • platform: harmony
    name: HARMONYHUB

That doesn’t cause any issues with HA loading but I don’t see the harmony remote show up anywhere and I don’t see the harmony.conf file either.

I verified on my router page that the harmony hub is at and my known_devices.yaml also shows the MAC address of the harmony hub at

Before I spend too much time troubleshooting this, I suppose I should ask, is is possible to get the state of my TV according to my Harmony Hub? Really, all I want to do is make sure the TV is off when I go to bed or leave my home zone.


Something is wrong with your network. Harmony through discovery is so easy. It just appears. Can you access your harmony with your phone? It uses the same protocol pretty much.

EDIT: Also, does harmony connect to your TV via rf? or is it over your network through a protocol? If it’s RF, harmony just guesses as to what the state is and harmony can get out of sync with it. Because of this, home assistant will have the same problem.

Make sure your firmware on hub is latest version, I believe .250

Cause 88.x requires it

Thanks for the follow-up. I must have messed something up somewhere. My Harmony hub is on the latest firmware but my HA install isn’t because it keeps getting an error trying to upgrade. Might just start fresh anyways once I order a new memory card for my Pi.

My phone does work with my Hub without issues.
My Hub and TV communicate via IR blaster.

Now that I’m thinking about it a bit more, I don’t need to know the state of the TV, because I can just send an off command. If the TV is already off it wouldn’t affect it, but if its on it will turn the TV off. I leave the rest of my devices on so that’s not an issue.

ok, explains, it
if your harmony is updated, then you also need ha 88.x again

So not sure if it was the version of HA I was on or something funky with my configuration but since I couldn’t upgrade my HA install anyways I just started fresh and the HUB showed up on first log in.

Thanks for the help.