Need help with double/triple tap and dimmer on HS-WD100+ Dimmers

I recently migrated from Homeseer to HA 0.107.7 on a RPi4. I have about 12 HS-WS100+ switches that I have successfully migrated to HA and am excited to start making some automations with them. I followed the instruction list here on how to update my zwcfg file and think I’ve got everything ready to go. I understand I need to use the scene_id and scene_data to use double/triple tap but am unclear as the syntax to use.

  • Does anyone have an example I could use as a template?
  • How can I add create automations setting the dimmer to a specific level?
  • How can I add a slider type control to lovelace for the dimmers

Thanks in advance.

The HS-WS100+ is a switch, but not a dimmer. First, be sure that it’s HS-WD100+ if you want the dimming functionality.

Here are the automations for double and triple clicks on one of mine:


####################################################
              Kitchen Counter Dimmer
####################################################

  - id: auto_kitchen_counter_triple_tap_up
    alias: Kitchen Counter Triple Tap Up
    initial_state: True
    trigger:
      platform: event
      event_type: zwave.scene_activated
      event_data:
        entity_id: zwave.kitchen_counter_lights
        scene_id: 1
        scene_data: 4
    action:
      - service: input_select.select_option
        data:
          entity_id: input_select.current_light_profile
          option: "Day"
      - service: tts.google_translate_say
        data_template:
          entity_id: media_player.kitchen
          message: Day mode
          cache: true

#-------------------------------------------------------------------

  - id: auto_kitchen_counter_double_tap_up
    alias: Kitchen Counter Double Tap Up
    initial_state: True
    trigger:
      platform: event
      event_type: zwave.scene_activated
      event_data:
        entity_id: zwave.kitchen_counter_lights
        scene_id: 1
        scene_data: 3
    action:
      service: homeassistant.turn_on
      entity_id: group.kitchen_lights

#-------------------------------------------------------------------

  - id: auto_kitchen_counter_double_tap_down
    alias: Kitchen Counter Double Tap Down
    initial_state: True
    trigger:
      platform: event
      event_type: zwave.scene_activated
      event_data:
        entity_id: zwave.kitchen_counter_lights
        scene_id: 2
        scene_data: 3
    action:
      service: homeassistant.turn_off
      entity_id: group.kitchen_lights

#-------------------------------------------------------------------

  - id: auto_kitchen_counter_triple_tap_down
    alias: Kitchen Counter Triple Tap Down
    initial_state: True
    trigger:
      platform: event
      event_type: zwave.scene_activated
      event_data:
        entity_id: zwave.kitchen_counter_lights
        scene_id: 2
        scene_data: 4
    action:
      - service: input_select.select_option
        data:
          entity_id: input_select.current_light_profile
          option: "Night"
      - service: tts.google_translate_say
        data_template:
          entity_id: media_player.kitchen
          message: Night mode
          cache: true

As far as an example for setting the brightness, I don’t have one exactly, but the action part should look something like this, where the brightness is a range from 0-255:

    action:
      - service: light.turn_on
        entity_id: light.kitchen_counter_lights
        data_template:
          brightness: 150

A “slider” would be use an automation that watches for a change in value of an input_number. So you could probably find an example on the forum by looking for that search term.

Good luck.

1 Like

Thank you that’s helpful. You are right about the HS-WS vs HS-WD. I have both, and got them confused.

So I got a little further but it’s still not working.

This is the automation I setup:

- id: 'billie_double_down'
  alias: Billie's Room Double Down
  trigger:
  - event_type: zwave.scene_activated
    platform: event
    event_data:
      entity_id: light.billie
      scene_id: 2
      scene_data: 3
  action:
    - service: scene.turn_on
      entity_id: scene.billie_bedtime

Here is the scene:

 - name: Billie Bedtime
   entities: 
     light.billie:
       state: on
       transition: 2
       brightness_pct: 20

And this is what shows up the ozw log when I double tap down on the dimmer:

2020-04-10 14:38:51.691 Detail, Node009,   Received: 0x01, 0x0d, 0x00, 0x04, 0x00, 0x09, 0x05, 0x5b, 0x03, 0x4b, 0x03, 0x02, 0xc9, 0x00, 0x21
2020-04-10 14:38:51.691 Detail,
2020-04-10 14:38:51.691 Info, Node009, Received Central Scene set from node 9: scene id=2 in 3 seconds. Sending event notification.
2020-04-10 14:38:51.691 Detail, Node009, Refreshed Value: old value=3, new value=3, type=int
2020-04-10 14:38:51.691 Detail, Node009, Changes to this value are not verified
2020-04-10 14:38:51.691 Detail, Node009, Notification: ValueChanged

Any help would be appreciated. TIA

So, the entity ID is actually going to be the zwave.xxxxx entry that corresponds with that dimmer. Not the light.billie. Look through the Developer Tools --> States and find the zwave.xxxx entry that has the same NodeID as your light.billie.

Im super new to HA, so this may be a silly question, but ive been searching for hours and this thread seems appropriate.

I have some HS-WD100+ dimmers, a pretty fresh install of HA (from last week), using a Zooz Z-Wave Plus S2 stick ZST10.

I have OpenZwave Beta and MQTT Mosquitto broker installed and configured, i have discovered the HS-WD100+ and it appears in my Device and Entity list. I can make an automation that works off the single click of the device using the gui, however any of the scripts using event_type: zwave.scene_activated and entity_id: zwave.device (with scene ID’s) dont work…

Under Developer Tools --> States there are no zwave.xxxx entries at all, just light.WD100

Looking at the OZW log, i can see the Central Scene notifications:
[ozw.library] [info]: Info - Node: 8 Received Central Scene set from node 8: scene id=1 with key Attribute 3. Sending event notification.

But i’m not sure how to use this within my automation scripts

Post the automation you are using, that will help to debug the problem

So I worked out this was related to using the OpenZwave beta rather than the built in zwave, i have since removed the beta and just used the built in version, its all working now…