Need help with home assistant and getting my Whole Home Smart

I bought couple of tablets that i would like to have home assistant so i can go ahead and make my home smart. I have the RBP4 8G and i found a YouTube channel ( that i did step by step how to set it up. That’s where everything goes down hill, After 10:40 into the video, it came down to static ip and port forwarding, that’s when i don’t know what to do. i have a Asus Router GT-AX11000. I tried my best in the setting WAN then Virtual Server/Port Forwarding. Server name: Home Assistant - Protocol: TCP - External Port: 443 - Internal Port: Blank Internal IP Address: Source IP: Blank. and restarted the router. Now i can not connect to RBP from the website nor the home assistant :8123 http:… NEED HELP. Been trying to two weeks now and don’t know how many YouTube videos to watch… I have a feeling its something to do with my router. And i forgot my RBP 8g is connect via Hardwire ethernet

I’m not sure why you need to set up port forwarding to access your HA from within your home LAN.

just set a static IP address and the you should be able to reach your HA at http://Static_IP:8123.

Once you have that working then you can set up external access if needed.

my router is a gaming router Asus Router GT-AX11000. I dont know where that is. My game plan is Connecting my Raspberrypi4 to my router hardwired, and connect my 3 tablets via wifi from a DNS website so i can insert them on the wall with my smart device apps connected to the tablets. Do you recommend anyone on youtube or can you help me step by step to set everything up. Up until the tablets all working. I think me adding the apps should be easy. The initial set up is the hard part. I watched this guy on youtube ( and did everything he did step by step up until the port forwarding. on my router its completely different

Have you looked at your routers documentation and searched for a section about static IP addresses or DHCP IP address reservations? That would be how you set a static IP address.

I still don’t know why you need port forwarding set up. Or now why you need a DNS server set up.

You will be accessing your HA from within your home LAN. you don’t need port forwarding for that.

No and no.

1 Like

im not computer expert, but just want to do a DIY smart home set up. So when you say HA i have no idea what that means, also the static ip for my system, it doesn’t really tell me where it is, the app for my router is very complicated. I use to have an IT guy but he no longer is with us, and i don’t know who can help me that i can pay a one time fee to set this all up for me.

Those two statements are mutually exclusive.

Anyway, you’re going to have to learn quite a bit if you want to do pretty much anything wth Home Assistant (HA for short).

It’s not really a system for someone who has no computer/programming skills at all.

If you can’t even read the documentation for your router to set up a DHCP reservation (especially after I gave you the terminology to search for) You are going to be in way over your head with anything else in HA.

But…just to give you a headstart I’ve looked up your router manual and if you look on page 77 it tells you how to set a static IP address (they call it a “manual IP address”)

1 Like

Thank you
as far as the DHCP. i add a Manually Assigned IP around the DHCP list. My router did see the (HA) mac address and the ip address witch i add and rebooted my router. after i tried to go on a website and type the url that my router sees for the HA and type in that address and it doesn’t open home assistant.
i think im almost there, once i get the url working with the HA i think i can figure the rest out.

Did you add the port number to that IP address?

You should find it at http://IP:8123


Wait, I just watched the video you linked and you said everything went OK until you needed to set up remote access.

Does that mean you already had access to your HA web address in your browser at some point?

I’m finally login to HA from Wi-Fi, I’m trying to set everything up remotely on my laptop and WOW with multiple websites i read and countless of YouTube i watched. I have installed file editor, home assistant google drive backup , samba share, check home assistant configuration. on my overview screen i have only weather. I keep going into Configuration add integration and i don’t see many of my products and if i do, i keep seeing a prompt that says Read Documentation and don’t know to do. next. This is all the "Smart Home Products i have. (2 Nest Thermostats) (Bond Ceiling Fan) (Lorex 16 NVR Camera System) (2 MyQ Garage Door Opener aka Liftmaster 8500w) (15Lurton Caserta Wall Switches) (4 Sonoff Mini that control lights on a schedule). I was thinking how this works is you go into integrations click on the product, input your user name and password and it should connect, But not at all :/. RBP did discover couple of items which i don’t want to have on my tablet are my Router, and Google Cast. Can you help (praying hands)

Have you tried searching for the products you have on the Integrations page? You need to do a bit of work to get HA up and running, it doesn’t just magically configure itself.

A less than 5 minute search of the HA website for some if the items you listed would have given you these configuration pages.

1 Like