Need help with Remotec ZTS-500US thermostat

Hello All,

I am new to Home Assistant. I started looking at Home Assistant when I started thinking of moving my Z-Wave sensors off of Wink. I am using Zooz S2 ZST10 USB stick. I was able to get all my sensors move over. Then to consolidate all my home automation to Home Assistant, I thought of getting a Z-Wave thermostat. I searched these forums and found that people have had success with Remotec ZTS 500US. But it does not seem to work well for me.

I am able to add the thermostat to the network, it shows up as a node, with two entities, a sensor and a climate entity.

1, none of those entities update with current data on the thermostat. I searched the forums and found about polling. Not sure if I should enable polling for just the sensor or the climate entity as well ?

2, if I enable polling for the sensor, it is able to update temperature, but the state maintained by climate entity in its attributes is not updated, eg hvac_mode, current_temperature, fan_mode remain unchanged at what they were when the network was started. My thought on this was just to enable polling for climate entity rather than the sensor, but wanted to hear if I am doing things right.

3, my thermostat does not report target_temp_high and target_temp_low, they are always set to 0. Thus the Lovelace card would always show the slider at 0,0 unless I change it. Does anybody know if I am doing anything wrong on this ?

4, I have tried calling ‘climate.set_temperature’ on climate entity with target_temp_high and target_temp_low, I can see commands being sent in ZWave logs and expected replies being received but the device is unreliable on the response. Sometimes it receives the message and responds accordingly but sometimes it feels as if the message is received but not acted on. Has anyone run into this and solved it ? How to make sure the device reacts, is there a minimum offset I need from the current_temperature ?

5, I found out that I need to send temperatures in ‘set_temperature’ call in C even if the device is configured to F and reports the current_temperature as F, I found that in zwcfg_xxxxxx.xml where the unit for SETPOINT is defined as C. Is there a way to change SETPOINT unit to F ?

Thanks in advance for any help anyone can provide.

  1. I found out that Remotec does not send updates to the controller. So I wrote python_script to do set_climate followed by refresh_entity.

  2. Polling only updates the primary index value or the state, thus I used refresh_entity to update all values.

  3. This might have been a temporary issue with the Lovelace card, this seems to work now.

  4. This is the main cause of all my remaining issues with Remotec ZTS-500US. I opened a case with Remotec and provided all the logs but no response from them yet. They tried pointing me in multiple directions but nothing fruitful yet. I have asked to be connected with an engineer but I am beginning to loose hope with Remotec on this.

  5. For this, I stopped home-assistant and then updated zwcfg_xxxxxx.xml file and restart home-assistant. That seems to reliably change the unit.

But I am still having issues mentioned in 4 in the original post. Effectively, my controller sends set_climate to Remotec ZTS-500, and receives the expected response but Remotec ZTS-500US does not act on the request. I have opened a case with Remotec but do not see any solution coming up from them yet.

After months of discussions with Remotec Support, I have not seen any solution from them. I have decided to move away from Remotec and switched to ADCT2000, ADCT3000 and Honeywell T6 Pro, these work as expected.