Need Help with Z-wave JS Troubleshooting

Hello all,

I’m looking for ideas on troubleshooting a Z-wave issue that has cropped up on my system. It has been stable for some months but after a power outage 3 days ago things aren’t stable with Z-wavel. All the other integrations seem to be fine.


Z-wave controller is a HomeSeer Z-NET which is a Raspberry Pi 3B with a Express Controls EZZee HAT installed. I belive this board is based on the 500 series chip. It’s been working fine for some months, with about 70 Z-wave devices connected. Z-Wave JS UI Addon is installed on a Supervised HASS install with TCP connection configured to the Z-NET. Z-Wave JS Integration points to the Addon instance.

If I restart the Z-Wave JS UI, everything will work for 10 minutes or so, then things just stop reporting. Watching the logs at debug level the normal Z-wave traffic stops and the logs start repeating this:

2023-02-03 16:06:18.283 INFO APP: GET /health/zwave 200 1.165 ms - 2005
2023-02-03 16:08:18.291 INFO APP: GET /health/zwave 200 1.167 ms - 2005
2023-02-03 16:10:18.297 INFO APP: GET /health/zwave 200 1.182 ms - 2005
2023-02-03 16:12:18.306 INFO APP: GET /health/zwave 200 1.229 ms - 2005
2023-02-03 16:14:18.319 INFO APP: GET /health/zwave 200 1.327 ms - 2005
2023-02-03 16:16:18.331 INFO APP: GET /health/zwave 200 0.824 ms - 2005
2023-02-03 16:18:18.337 INFO APP: GET /health/zwave 200 1.757 ms - 2005
2023-02-03 16:20:18.345 INFO APP: GET /health/zwave 200 1.196 ms - 2005

It’s like the TCP connection to the Z-NET has gone silent. A restart of the Addon will repeat the process. During the health URLs above, any interacting with lights or devices will generate a ZW0202 error after a few seconds.

ERROR Z-WAVE-SERVER: Failed to send the message after 3 attempts (ZW0202)

At first I thought maybe something happened to the Z-NET, and I have a spare, but to separate software problem from hardware problem, I shut down the Z-Wave JS UI addon and fired up my previous software connected to this device (HomeSeer). I enabled Z-Wave and turned on logging and everything worked fine. I watched it for an hour and a half and everything was still working and controllable. I shut that down and restored a Home Assistant backup from prior to the power outage, 5 days ago. Still had the same symptoms. Everything works fine for the first few minutes, then Z-wave traffic goes silent and stops working.

Not sure where to go from here. Any advice is appreciated.

Zwavejsui has a log. Check there

Zwavejsui shows tx/rx stats for each device. Check that.

The log lines I posted are from the Z-wave JS UI log.
When the problem occurs, all the devices stop responding, not just a few. All the device tx/rx stats seem normal while things are working.

Last night I did some more testing, checking network connectivity between the Z-NET, HASS VM and addon and HASS docker containers. Everything is wired and within 6 feet of each other. No issues there. While checking the Raspberry Pi that hosts the Z-wave HAT I noticed that the TCP connection gets dropped when the problem occurs. The ser2net configuration on the Pi had a 120 second idle timeout. I changed that to 0 and things stayed up and working throughout the night. I’m monitoring now to see if that was the issue. Not sure why that suddenly would cause a problem.

Well, the 120 second idle timeout on ser2net seems to have been the culprit. Not sure why my z-wave traffic patterns have slowed to where this suddenly became an issue. Also not sure why Z-wave JS UI wouldn’t reconnect automatically, but the issue is resolved for now.


So, I have the same issue with the timeout. I tried 60s and then 120s. I’m trying 0s now, but not sure I like that. Then again I only have a lock on this z-net so it’s possible that my config just isn’t suited well for this. I may add a small z-wave device that just reports, but I hate adding devices just for that sake.