Need some assistance with RTSP link using secrets.yaml

I have a Hikvision camera where the syntax is:

  • platform: ffmpeg
    name: Ch0
    input: -rtsp_transport tcp -i rtsp://User:[email protected]/streaming/Channels/1

I tried adding the URL to the secrets.yaml file
Secret_url: -rtsp_transport tcp -i rtsp://User:[email protected]/streaming/Channels/1
And changed the configuration.yaml to the following

  • platform: ffmpeg
    name: Ch0
    input: secret! Secret_url

Unfortunately this method does not work …
Tried adding “rtsp…” but it did not help as well
I get following error on logs
Error opening stream Secret_url

1:58:17 PM – (ERROR) Stream - message first occurred at 1:40:01 PM and shows up 30 times
Source: components/stream/
Integration: Stream (documentation, issues)
First occurred: 1:40:01 PM (30 occurrences)
Last logged: 1:58:17 PM

Any assistance will be highly appreciated

Where does that come from?

!secret Secret_url
1 Like

@koying :crown:
I am very embarrassed :upside_down_face:
Must admit all other places I used “secret!” which worked… so I copy paste with the same mistake.
Thanks a lot !!
Its working :boom: