Need some help getting garage door to open with Home Assistant, Google Home/Assistant Integration

Hello all, I hope someone here can help me with the subject. I can’t quite figure it out and I’m fairly certain I’m just not getting sometthing right or I am leaving something out. Also, I have everything else in my smart home working with the home assistant, google assistant integration (door locks included, code is asked for on unlock and works).

So I don’t really know where to start so I’ll start at the beginning. The garage door works when clicking the button on the lovelace dashboard. It is a cover entity. I have used the states developer tab, along with the history sidebar tab to determine the nomenclature my door uses is “closed” and “open” and “opening”. I think at least unless you can’t actually interact with it using those words in code/ yaml. I know next to nothing about yaml. In my configuration.yaml for the garage door, I have these lines:

      name: "Garage Door"
      room: "Garage"
      expose: true

The configutation validates. When I say “Hey Google, open the garage door”, the response is “Sorry, i didn’t understand”. Last thing I can add is when I go to the device in the google home app and click it, it takes me to a page which has no controls for the garage door on it. At the bottom of the tab it says, connected through: Home Assistant, Manufacturer: Nortek Security and Control LLC, Name from Home Assistant: Garage Door, Device type: Garage. I have no “customize:” area in my configuration.yaml and don’t really understand what I have read about that subject.

Thank you all for any help you all can give me with this. I would really appreciate it if someone could help me figure this out. Thank you all!!

I don’t have a garage, but since there is a service call that works I think all that needs to be done is to make sure the service calls are exposed to Google home.

When you run a script with voice you need to say “activate [script name]”, don’t know what covers need.
But you could create a script that if garage is open closes it and vice versa then expose the script to Google home.
That should work.
What you then could do is create a routine in Google home that triggers on “open garage” and “close garage” and the action “activate garage script”

Did you set a secure_devices_pin? This is required in order to expose secure devices to google such as locks, alarm control panels, doors, garage doors and gates. See here for more information.


Just to confirm, in addition to saving the config you are also restarting Home Assistant and then saying “sync my devices” to google right? You have to do both of those things in order to expose new stuff from HA to google.

I do have the “secure_device_pin” set and it is working appropriately on my standard exterior door locks around the house.

I will do your second statement one more time just to confirm. I will report back shortly. – I’m fairly certain the answer is yes to both of your inquiries, because the Garage Door entity shows up in my google home app already but the previous statements I said here are what is occuring. I’ll give it one more go to be doubly sure of my response though.

Ahhh, I follow you here. Worst case I will go some route like this but I really prefer to get this working as it’s designed. Thank you for the idea should I have to go that way!

I’m a legitimate idiot. It is working now. It was user error. (Routine that i forgot was in my account). When I have more time later today, I’ll come back and edit this post for what happened. Thank you for trying to help me though!!

1 Like

So I used to have some routines in my account of “open the garage door” and “close the garage door”. In the routines I had “turn on the garage door” and “turn off the garage door”. Essentially my routine was causing google to use commands that aren’t possible when it is the “cover” entity type. This was a leftover from having the garage door as a switch when i used to use SmartThings.