Need some help getting SmartThings running

I’m trying to get Smartthings running with home assistant. I’ve been following this guide but I really feel like I’m kind of lost.

I get lost with the /opt/mqtt-bridge/config.yml. Should I just make it from scratch? That is what I did, and I put the two lines of code in the file (is the — important?). For IP of the host, do I put the IP of the Raspberry Pi I’m using as my HomeAssistant server? Do I use the local network address or public network address?

For the Smartthings Device, I assume I’m putting the information for the Raspberry pi.

For configuring Home Assistant, I put in those two lines of code but HA says my mqtt isn’t configured correctly. I tried changing it from localhost to the local IP, but same thing. Same result with mqtt://

That’s pretty much as far as I’ve gotten. Any help would be appreciated

As a note, you should have set up an MQTT broker.

For the MQTT bridge configuration, I find that the example on the Github description works pretty well (under Configuration):

    # Specify your MQTT Broker URL here
    host: mqtt://localhost
    # Example from CloudMQTT
    # host: mqtt:///

    # Preface for the topics $PREFACE/$DEVICE_NAME/$PROPERTY
    preface: smartthings

    # Suffix for the state topics $PREFACE/$DEVICE_NAME/$PROPERTY/$STATE_SUFFIX
    # state_suffix: state
    # Suffix for the command topics $PREFACE/$DEVICE_NAME/$PROPERTY/$COMMAND_SUFFIX
    # command_suffix: cmd

    # Other optional settings from
    # username: AzureDiamond
    # password: hunter2

# Port number to listen on
port: 8080

You put the IP of wherever the MQTT broker is located (usually your Pi as well but not always) and you’ll use the local network address if you are running everything on the same network (again, this is usually the case as they are on the same box). The IP address is so that the bridge can communicate to your MQTT broker.

For configuring Smartthings Device, you’ll put the information of wherever your bridge will be running (most likely on your Pi so the answer to your question is probably yes). This so your SmartThings Hub can talk to your bridge (both usually on the same network so you can probably put your local network address of where your bridge is located as well).

For Home Assistant, make sure you are putting the IP address of the MQTT broker you’ve set up.