Need some help to make my name appear with OwnTracks

Hi folks, I expect this is straightforward but I can’t find the solution. I’ve got OwnTracks running successfully on my iPhone and connected to HA through CloudMQTT so that my position IS showing on the dashboard accurately. But I’m showing as the randomly assigned CloudMQTT username (half a dozen random lower case letters). How can I change that so it shows “Alison”, and a pic would be nice !
Thanks very much

You should be able to do both by editing your known_devices file and finding the entry for your device tracker on owntracks, then add something like:

name: Alison
picture: <url of some picture on the internet>

You can also use local files. I looked for a link in the docs to all of this but I am drawing a blank. If you search the forum there is a post on grabbing your facebook picture which is a cool idea.

Thank you @aimc That worked perfectly. It’s also helping me find my way around HA, much of it by trial and error :slight_smile:

Glad it helped :slight_smile: I struggled a lot with the presence stuff and ended up finding out how it worked mostly by experimentation and reading the code.

I just redid my owntracks set up and wasn’t getting updates to my presence. Drove me crazy trying to figure out the disconnect. Finally found out what was wrong, but I don’t recall it being described in the how to set up Owntracks. I use a private MQTT server (no security in this instance, put it in)

So as a record (in case I’m dumb enough to nuke my config and have to redo it) and maybe helping someone else setting up Owntracks, I’ll describe my setup:

  • Install owntracks on your iphone
  • open the app and tap the i in the upper left hand side. Status info will show.
  • tap settings (in blue)
  • Set Mode to Private
  • Set TrackerID is initials (RR in my case)
  • Set DeviceID to your last name (robinson in my case)
  • Set your host name to the MQTT URL ( in my case)
  • Set your port (91883 in my case)
  • Set TLS as you need (or turn off)
  • Set Authentication (on or off)
  • Set UserID to your first name (rene in my case) (To do this you must turn on authentication to make the field accept input)

The secret sauce is to use the UserID is the firstname and the DeviceID is the family name.

In your known-devices.yaml file make sure you have something like this:

  hide_if_away: false
  mac: 12:34:56:78:90:AB
  name: 'Rene R'
  track: true
  vendor: Apple, Inc.

Restart the server:

$\> sudo systemctl restart home-assistant

That should do it…

Rene’ R